On Sat, 11 Feb 2012 07:04:48 +0100
Peter Baumgartner <peter.baumgart...@donau-uni.ac.at> wrote:
> My assumption is that there is a memory problem:
> 
> 1. I can compile every part of the book as long as I'm not compiling
> the whole book at once.
> 2. I can compile the whole book without problems in draft modus e.g.
> without integrating the pictures
> 3. To compile just a part but to tell LyX it should include counter
> and references results in the same error.

Probably not a memory problem: I compiled a document yesterday with
about 250 images, producing a PDF file of 280 pages and 325MB.
> 
> I have not idea how to proceed: If I compile the book in two
> independent parts what about the int-text references, bibliography
> and other automatic generated lists (table of contents, table of
> figures etc.)?

You shouldn't have to do that.
> 
> Could a new organisation of the files helpful? (At the moment I have
> one master file with 53 subfiles.)

That shouldn't make any difference.

> Another possibility I'm thinking of are the pictures itself. In my
> first version the pictures had about 80 to 300 kB. After shooting the
> screenshots again half of them have now 200 kB to 700 kB (still bad
> resolution but maybe sufficient?) the other half is between 2 to 4
> MB. All the pictures are in PNGs. Perhaps it would help to size the
> biggest pictures a little bit down? But here the problem is: To some
> of the websites I have no access anymore and all the pictures have
> overlaid graphics in it (to highlight some part of the screenshot).  

The size of the graphics is not a problem, but there is probably one
particular image which is giving you a problem.

> I'm at a loss and don't know how to proceed. Any hint would be *very*
> appreciated...

I'd suggest the following process:

1. Export to LaTeX (pdflatex)

2. Run pdflatex on the exported file. It will stop at the problem.

3. Use the 'E' command to edit the file, removing anything suspicious
around the point where it stopped.

4. Rerun pdflatex, repeating until you get it to run properly.

5. Go back to LyX and remove and re-enter the bits where pdflatex had
problems.

That process  has solved similar problems for me in the past.

One frequent problem is spaces in filepath names: they sometimes work
and sometimes don't. The best solution is to remove them.

Les

Reply via email to