On 03/02/2012 04:00 AM, Jonas Lindh wrote:
My only working solution to problems with bibtex has unfortunately been to leave Lyx and clean up plain latex and compile...
I have basically tried everything to get this to work in lyx...

This is very hard to debug remotely, I'm afraid.

Richard

Jonas

--------

http://www.ling.gu.se/~jonas <http://www.ling.gu.se/%7Ejonas>


2012/2/27 Jonas Lindh <jonas.lindh...@gmail.com <mailto:jonas.lindh...@gmail.com>>

    When I create a test file and use same bst or different (plainnat)
    I get the same errors from bibtex... I am still presuming I have
    to put the bsts yet some other place, but they are all over now...
    any input more on this?
    Best regards
    Jonas


    2012/2/27 Jonas Lindh <jonas.lindh...@gmail.com
    <mailto:jonas.lindh...@gmail.com>>

        According to http://tug.org/mactex/faq/#qm04 I should put my
        bst file under ~/Library/texmf/tex/ which I have already done
        (also tried several other places, so I can't understand why it
        can't be read?
        Jonas


        2012/2/24 Jonas Lindh <jonas.lindh...@gmail.com
        <mailto:jonas.lindh...@gmail.com>>



            On Friday, February 24, 2012, Richard Heck wrote:

                On 02/24/2012 08:46 AM, Jonas Lindh wrote:
                > Hi.
                > After updating etc I can't seem to get my references
                into the compiled
                > pdf using lyx 2.0.2 on macosx 10.7.3 and a bst that
                used to work great
                > from a professor at my dept. MacTeX 2011 is
                installed and updated
                > using Tex live...
                >
                > I am attaching the bst.+AKA-
                >
                > The output gives me (?) for refs and error for
                bibtex is :
                > This is 8-bit Big BibTeX version 0.99d
                > Implementation: +AKA-C for Unix
                > Release version: 3.71 (31 May 2005)
                >
                > Error: cannot open CS file: 88591lat.csf
                > The top-level auxiliary file: thesis+AF8-vers16.1.aux
                > I couldn't open style file
                >
                
45+AF8-Users+AF8-jonas+AF8-Dropbox+AF8-thesis+AF8-version16+AF8-mybib.bst
                > ---line 1387 of file thesis+AF8-vers16.1.aux
                > +AKA-:
                >
                
+AFw-bibstyle+AHs-45+AF8-Users+AF8-jonas+AF8-Dropbox+AF8-thesis+AF8-version16+AF8-mybib
                > +AKA-: +AKA- +AKA- +AKA- +AKA- +AKA- +AKA- +AKA-
                +AKA- +AKA- +AKA-
                > +AKA- +AKA- +AKA- +AKA- +AKA- +AKA- +AKA- +AKA-
                +AKA- +AKA- +AKA-
                > +AKA- +AKA- +AKA- +AKA- +AKA- +AKA- +AKAAfQ-
                > I'm skipping whatever remains of this command
                > I couldn't open database file
                >
                
44+AF8-Users+AF8-jonas+AF8-Dropbox+AF8-thesis+AF8-version16+AF8-thesis+AF8-vers16.bib
                > ---line 1388 of file thesis+AF8-vers16.1.aux
                > +AKA-:
                >
                
+AFw-bibdata+AHs-44+AF8-Users+AF8-jonas+AF8-Dropbox+AF8-thesis+AF8-version16+AF8-thesis+AF8-vers16
                > +AKA-: +AKA- +AKA- +AKA- +AKA- +AKA- +AKA- +AKA-
                +AKA- +AKA- +AKA-
                > +AKA- +AKA- +AKA- +AKA- +AKA- +AKA- +AKA- +AKA-
                +AKA- +AKA- +AKA-
                > +AKA- +AKA- +AKA- +AKA- +AKA- +AKA- +AKA- +AKA-
                +AKA- +AKA- +AH0-
                > I'm skipping whatever remains of this command
                > I found no database files---while reading file
                thesis+AF8-vers16.1.aux
                > I found no style file---while reading file
                thesis+AF8-vers16.1.aux
                >
                I'm not sure what you updated, but it looks as if
                LaTeX simply isn't
finding the bst file.

            I ran tex check... Then checked log - bibtex

                It also looks as if LyX is copying it to your
                temporary directory, and THEN LaTeX isn't finding it.
                This may be due to
some changes in how local files are handled in 2.0.2.

            Suspected that too and put it in the same folder as the
            lyx doc, but also in tex folders I could think of and find
            documentation of, but didn't help, maybe need to put in
            yet another path, somebody knows where it's looking on
            mac/unix?

                I'd suggest that
                you put the bst file in some location where LaTeX will
                find it without
                its having to be copied to the temporary directory.
                Where this is on
                Mac, I'm afraid I do not know.

                After you get this error, you might also look in the
                temporary
                directory. Is the referenced file there?


            Which tmp? Lyx?
            Thanks for answering so quickly...
            Jonas


                Richard



-- --------
            http://www.ling.gu.se/~jonas <http://www.ling.gu.se/%7Ejonas>




-- http://www.ling.gu.se/~jonas <http://www.ling.gu.se/%7Ejonas>





-- http://www.ling.gu.se/~jonas <http://www.ling.gu.se/%7Ejonas>





--
http://www.ling.gu.se/~jonas <http://www.ling.gu.se/%7Ejonas>



Reply via email to