Yesterday I had a friend call me for advice on a Windows XP
installation of Lyx. He had been using LyX for several years without
any problems, and had just updated to Now he could work in
LyX, but could not generate a PDF output. He is running Windows XP on a

To investigate how LyX works on Windows so I could give him advice I
borrowed the only computer in the house with Windows, my wife's
netbook, which dual boots Windows 7 and Linux Mint.

I downloaded the bundle, LyX-, and installed it in
Windows 7. I found I had exactly the same problems my friend was

To investigate what was happening, I tried to export LaTeX(pdflatex),
using the splash file (examples/splash.lyx) as a test case. It exported
what looked like a perfectly good LaTeX file. I looked around for a way
of testing this file, and found TeXworks, which comes with MikTeX. It
generated a perfect PDF file with no errors.

So I went back to LyX, opened the Messages box to watch where the error
occurred, and tried to export a PDF(pdflatex) file. It worked without
any errors.

So I tried another file (the User's Guide, doc/UserGuide.lyx). This
also worked without any errors, but I observed that before generating
the PDF MikTeX downloaded some additional packages.

So I suggested to my friend that he try exporting a LaTeX file,
typesetting it using TeXworks, then trying again with LyX. Sure enough,
after using TeXworks to generate one PDF file, LyX can create PDF files

I have to conclude that the MikTeX installer does not finalize the
installation, but leaves something undone. This missing configuration
is then completed the first time TeXworks is used. Perhaps someone more
familiar with MikTeX could explain this.


Reply via email to