OK-- further research uncovered the culprit for the first issue (the need to accept any change made before I could compile). 
In my preamble I had the following:

\usepackage{enumitem}

\setlist{leftmargin=0mm, itemindent=3mm, itemsep=0.75mm,nolistsep}

\usepackage[pdftex,outerbars]{changebar}

\renewcommand{\lyxadded}[3]{{\cbstart\color{lyxadded}{}#3\cbend}}

\renewcommand{\lyxdeleted}[3]{{\cbstart\color{lyxdeleted}\sout{#3}\cbend}}


Commenting these lines out solved the problem.  I have not yet discovered the reason for the failure to correctly reference a wrap figure in a box.

Ehud Kaplan

On 02/07/2013 01:03 AM, Scott Kostyshak wrote:
On Tue, Feb 5, 2013 at 8:46 AM, EK <ehud.kap...@gmail.com> wrote:
Here is a SmallWorkingExample, which illustrates both issues.
Here the reference to the figure appears as Figure .... (no number).

Ehud Kaplan
Hi Ehud,

Thank you for your example file. However, it is not a working example
file for the following reasons:
1. It does not compile.
2. You did not include your bibtex file. If it's not necessary to
reproduce the problem, then consider not making it a dependency by
including references in your MWE .lyx file.
3. Even if you did include your bibtex file, the path to it is
specific to your computer.
4. You did not include the file p-trode-w-dimensions. Further, because
this file has no name, I have no idea what time of graphic it is. And
thus I have no idea what converter is being called.
5. The path to the picture is not relative.

An MWE (or a SWE) should be compilable out of the box.

You probably didn't send the picture because you didn't want to
increase the size of everyone's inboxes and I appreciate that. But
it's very nice to have an MWE. I wish we had a way where you could
upload your files somewhere and then link to them because not everyone
has access to such a service themselves. Also, you could have used a
1kb picture, or no picture at all, to show the problem.

Regarding your potential bug number 1, I think I see what you are
talking about. Here is the PDF that is produced for me on the
development version of LyX:
https://www.dropbox.com/s/e5rpv153nue0lg0/MWE.pdf
There is no number at all in the reference to the figure. It should be
figure 1 and yet nothing shows up.

Regarding point 2, I didn't try to reproduce this as I have no idea
what converter is being called and I'm not sure if by "any change to
the figure" you mean a change to the file itself, a change to the
properties of the figure, a change to the caption, or maybe all of the
above. Please specify just one action in the steps you give to
reproduce the behavior you found. You can then note that any of
several actions could also be used for that step.

I hope I'm not coming across as upset. I'm not at all. I think that it
takes time to learn how to write a good MWE. I also think that we are
missing documentation on how to make an MWE specifically in the
context of LyX. A search for "MWE" at wiki.lyx.org gives nothing. This
is something I would like to work on documenting. Let me know if you
have any suggestions for me.

My guess is that these are LyX bugs. If you are able and willing to
make MWE(s) (either one that shows both problems, or two separate
ones), it would be great if you could open separate bug reports on
www.lyx.org/trac. Please attach any relevant files to each bug report.

Best,

Scott

--
Ehud Kaplan, Ph.D.
Jules and Doris Stein Research to Prevent Blindness Professor
Director, The laboratory of Visual & Computational Neuroscience
Director, Center for Excellence in Computational & Systems Neuroscience
Friedman Brain Institute
Departments of Neuroscience, Ophthalmology, Structural & Chemical Biology,
The Ichan school of medicine at Mount Sinai
One Gustave Levy Place,
NY, NY, 10029

Reply via email to