On 06/07/2014 10:12 PM, Julio Rojas wrote:
Dear all,

I have just tried to install Lyx 2.1 on my Windows 7 PC on which I already had Lyx 2.0.6 and TexLive 2013, so I went the update way. During configuration, Lyx runs LuaLatex which in turn gets stuck and start bloating and eating all the resources. I tried killing the script (python.exe). Lyx starts telling me that there were no classes installed. I tried reconfigure, but had the same result.

Has somebody had this problem?

For some reason, the lualatex configuratoin check takes a very long time. I don't know why it would cause such huge problems, but if you want to work around this:

1. Find the configure.py script on your system. It should be in your LyX system (library) directory, which you can find from Help> About LyX.

2. Open the file and find the checkLuatex() routine.

3. At the very beginning of that routine, put: return, to skip the rest. Make sure the indentation is right, as python cares about that. A lot.


Reply via email to