Am 11.06.2014 09:47, schrieb Wolfgang Engelmann:

Am 10.06.2014 22:26, schrieb Alex Vergara Gil:
----- Original Message ----- From: Wolfgang Engelmann Sent: Tuesday, June 10, 2014 2:19 PM

Thanks, Alex, for the new lyx file. I now realized, that I had to load the matplotlib and pandas packages, which I did. I followed your advices Define a new file format in tools>preferences, name it Python graphics, extension pygr and vector image format ticked Define a new converter from the format Python graphics to the format EPS as ... After reconfigure (necessary?) and making sure the two example graphics (in pygr format) are found in the path I get this error
No, reconfigure is not necessary
LaTeX Warning: File `0_home_we_Lyx_PhytonGraphics_example.eps' not found on input line 83.
Why is it expecting an eps file instead of taking the pygr files?
indeed a eps file is expected
What am I missing?
Wolfgang
Did you can see the graphic within LyX? Did LyX display it correctly in your system? if not the case check that the example script is located at the same path than the lyx file, another way is to click in the inserted graphic and look for the example.pygr path

Yes, all this is ok. However, both graphics (example.pygr, example2.pygr) show: Error converting to loadable format.



Another possible explanation is that your system doesn't handle with eps, in this case you should change the definition and instead of eps, put pdf or png as final format, whichever work for you, you can check that because it will display the graphic within LyX even before you export anything!

I have changed to png, now the first example renders alright (in LyX), but the second one not. Shouldn't your LyX file contain already your tools>preferences settings? Or how can one make LyX remember these settings, so that people trying it have not to fiddle with it?
Wolfgang

Sorry, I should have read the last part: Using more advanced python libraries are also allowed, like this example using seaborn, scipy and numpy. To obtain extra python packages you have to install the python-pip package manager and perform“pip install package” with root permissions, where package can be seaborn for instance. So I will try installing this and hope it will work. An additional question I will mail separately. Wolfgang


Reply via email to