Thanks for pointing that out. Besides I'm currently fixing another problem along with gnucash: It doesnt find its docs. I'm actually getting closer to a solution, so I think I'll upload a new revision later this day.
Kind regards Thomas Ryan Schmidt wrote: > On Mar 17, 2008, at 12:47, [EMAIL PROTECTED] wrote: > >> Revision: 35110 >> http://trac.macosforge.org/projects/macports/changeset/35110 >> Author: [EMAIL PROTECTED] >> Date: 2008-03-17 10:47:47 -0700 (Mon, 17 Mar 2008) >> >> Log Message: >> ----------- >> gnucash 2.2.4, fixing: >> #14297 (Update gnucash) >> #13316 (binreloc error) >> #13472 (Fails to build on leopard) >> #13852 (Fails to compile) > > [snip] > >> -default_variants +guile16 >> +default_variants +guile16 +without-docs > >> -variant without_docs { >> +variant without_docs description {Does not build gnucash-docs} { >> depends_lib-delete port:gnucash-docs >> } > > In the default variants, hyphen is not a valid character in variant > names, and the variant is in fact named without_docs (with an > underscore, not a hyphen). > > However, if you're going to make it the default to build without > documentation, then the variant should be changed to be called "docs" > (or "with_docs" if you insist on that nonstandard naming convention). > Default variants are buggy during upgrades and should be avoided. > _______________________________________________ macports-dev mailing list [email protected] http://lists.macosforge.org/mailman/listinfo.cgi/macports-dev
