I get exactly the same error output; however, I'm upgrading (or trying to) from "vim @7.2.021_0 (active)". Also lots of xorg upgrades that succeed and a python that doesn't. Frustrating! openssl and vim are the only active ports that are outdated and won't upgrade on my system.

On Jan 18, 2009, at 5:06 PM, Mark Hattam wrote:

Did a selfupdate on Macports 1.7 running on OSX 10.5.6, then a port outdated ...

iMac:~ mark$ sudo port outdated
The following installed ports are outdated:
vim                            7.2.077_0 < 7.2.077_1

iMac:~ mark$ sudo port upgrade outdated
--->  Fetching vim
--->  Verifying checksum(s) for vim
--->  Extracting vim
--->  Applying patches to vim
--->  Configuring vim
--->  Building vim
Error: Target org.macports.build returned: shell command " cd "/opt/ local/var/macports/build/ _opt_local_var_macports_sources_rsync .macports.org_release_ports_editors_vim/work/vim72" && make all " returned error 2 Command output: /usr/bin/gcc-4.0 -c -I. -Iproto -DHAVE_CONFIG_H -I/ opt/local/include -DMACOS_X_UNIX -no-cpp-precomp -I/Developer/ Headers/FlatCarbon -O -D_FORTIFY_SOURCE=1 -o objects/ quickfix.o quickfix.c /usr/bin/gcc-4.0 -c -I. -Iproto -DHAVE_CONFIG_H -I/opt/local/ include -DMACOS_X_UNIX -no-cpp-precomp -I/Developer/Headers/ FlatCarbon -O -D_FORTIFY_SOURCE=1 -o objects/regexp.o regexp.c

[lots more of these FORTIFY_SOURCE lines ending with ...]

/usr/bin/gcc-4.0 -c -I. -Iproto -DHAVE_CONFIG_H -I/opt/local/ include -DMACOS_X_UNIX -no-cpp-precomp -I/Developer/Headers/ FlatCarbon -O -D_FORTIFY_SOURCE=1 version.c -o objects/ version.o /usr/bin/gcc-4.0 -L/opt/local/lib -o vim objects/buffer.o objects/charset.o objects/diff.o objects/digraph.o objects/edit.o objects/eval.o objects/ex_cmds.o objects/ex_cmds2.o objects/ ex_docmd.o objects/ex_eval.o objects/ex_getln.o objects/fileio.o objects/fold.o objects/getchar.o objects/hardcopy.o objects/ hashtab.o objects/if_cscope.o objects/if_xcmdsrv.o objects/main.o objects/mark.o objects/memfile.o objects/memline.o objects/menu.o objects/message.o objects/misc1.o objects/misc2.o objects/move.o objects/mbyte.o objects/normal.o objects/ops.o objects/option.o objects/os_unix.o objects/pathdef.o objects/popupmnu.o objects/ quickfix.o objects/regexp.o objects/screen.o objects/search.o objects/spell.o objects/syntax.o objects/tag.o objects/term.o objects/ui.o objects/undo.o objects/window.o objects/ os_macosx.o objects/os_mac_conv.o objects/netbeans.o objects/ version.o -lm -lncurses -liconv -framework Carbon
Undefined symbols:
 "__Xsetlocale", referenced from:
     _get_locale_val in ex_cmds2.o
     _ex_language in ex_cmds2.o
     _ex_language in ex_cmds2.o
     _ex_language in ex_cmds2.o
     _main in main.o
     _main in main.o
     _enc_locale in mbyte.o
     _mac_lang_init in os_mac_conv.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[1]: *** [vim] Error 1
make: *** [all] Error 2

Error: Unable to upgrade port: 1

Previous updates to VIM have worked OK.

iMac:~ mark$ sudo port installed | grep vim
 vim @7.2.077_0 (active)

Previously today, gd2 was updated
--->  Deactivating gd2 @2.0.35_2
--->  Installing gd2 @2.0.35_3

whose upgrade process downloaded, built, installed and activated 70 (seventy) xorg- packages ...


macports-users mailing list

Attachment: smime.p7s
Description: S/MIME cryptographic signature

macports-users mailing list

Reply via email to