Hello,

I have installed macports on my new MacBook.  I installed xorg-server, gnome3-core, gnome-desktop, and gnome-session packages but cannot launch gnome-session.  I get the following output:

Charlies-MacBook-Pro:~ me$ gnome-session
Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Using null backend for session tracking Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.Shell' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.A11yKeyboard' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.A11ySettings' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Clipboard' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Color' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Datetime' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Housekeeping' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Keyboard' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.MediaKeys' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Mouse' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Power' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.PrintNotifications' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Rfkill' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.ScreensaverProxy' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Sharing' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Smartcard' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Sound' Apr 10 01:05:40  gnome-session-binary[46032] <Warning>: WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Wacom'

I checked to see if gnome-settings-daemon was installed and it is.  I installed gedit to check X11 and it works perfectly well.

What do I need to do to get it to load?

Thanks,

Charlie

Reply via email to