On 12/04/18 04:24, Ryan Schmidt wrote:

On Apr 11, 2018, at 21:54, Joshua Root wrote:

On 2018-4-12 12:39 , Ryan Schmidt wrote:

On Apr 11, 2018, at 10:23, Joshua Root wrote:

No, rsync just hasn't updated yet. The ports are also a bit out of date.
Ryan should be able to take a look before too long.

mprsyncup is failing with:

2018-04-11T02:10:34+0000 error: pathspec 'v2.4.3' did not match any file(s) 
known to git.

I guess GitHub changed something? That's the format we've been using
since 2.3.5.

Maybe mprsyncup has not retrieved the new list of tags. We had that problem 
last time, and Rainer fixed it:

https://github.com/macports/macports-infrastructure/commit/bb8f7886c9c086d80cfdde35d6c7402bd61675b6

But I ran "git tag" in /Volumes/RAID/var/tmp/mprsyncup/release/base and it 
listed every tag up to v2.4.2 but not v2.4.3.

2018-04-12T03:16:17+0000 + read -r RELEASE_URL
2018-04-12T03:16:17+0000 + '[' -z 
https://github.com/macports/macports-base/tags/v2.4.3 ']'
2018-04-12T03:16:17+0000 + RBASE_CHANGED=1
2018-04-12T03:16:17+0000 + '[' -d 
/Volumes/RAID/var/tmp/mprsyncup/release/base/.git ']'
2018-04-12T03:16:17+0000 + cd /Volumes/RAID/var/tmp/mprsyncup/release/base
2018-04-12T03:16:17+0000 + /opt/local/bin/git fetch -q --tags
2018-04-12T03:16:18+0000 ++ /opt/local/bin/git rev-parse HEAD
2018-04-12T03:16:18+0000 + 
RBASE_OLD_REV=68708e1c5e2a4f21afa95e733c5d34cd0f5c71de
2018-04-12T03:16:18+0000 ++ /usr/bin/basename 
https://github.com/macports/macports-base/tags/v2.4.3
2018-04-12T03:16:18+0000 + /opt/local/bin/git checkout -q v2.4.3
2018-04-12T03:16:18+0000 error: pathspec 'v2.4.3' did not match any file(s) 
known to git.

Maybe I am barking up the wrong tree, but does it mean anything that the link

https://github.com/macports/macports-base/tags/v2.4.3

leads to "Not Found"

where as

https://github.com/macports/macports-base/tags/

lists the tags fine, and clicking on 2.4.3 leads to

https://github.com/macports/macports-base/releases/tag/v2.4.3

Is it just the link is wrong (changed) ??

Reply via email to