"Dominic Reich" <domi...@mm.st <mailto:domi...@mm.st>> wrote:

> You should be able to print without any additional software (except the 
> driver that macOS retrieves from its Servers). But you won't need any 
> package from MacPorts for printing.
> Besides that, postgresql83-server is a database. You won't need a 
> database to print stuff.

This is going to be long, boring and somewhat irrelevant. If you’re busy, move 
on to the next thread.

Bottom line is that when you have an old, ignorant and naive person like me 
trying to use something like MacPorts, this stuff is going to happen.

Let’s examine the timeline.

On Tuesday morning the first thing I did was print a mailing label I needed to 
return a failed disk drive to Western Digital for warranty replacement. That 
print job executed without issue.

The next thing I did was to update MacPorts. That’s when I got the error 
message on postgresql83. After exchanging a few messages with other members of 
this list I decided to delete postgresql83. That was sometime after lunch. 
After that I didn’t do anything on the iMac. I watched some TV, read a novel, 
worked in the garden, had a beer for happy hour and ate dinner. (I’m retired.)

The next morning the first thing I did was try to print something. I’m both 
surprised and shocked that the print system has simply disappeared. In my mind 
I associate the last thing I did on Tuesday (delete postgresql83) with the 
first thing I tried to do on Wednesday morning (print something). So I assume 
(wrongly, I guess) that deleting postgresql83 had something to do with the 
disappearance of the printing system. What else could it have been? I’m the 
only one who uses this computer and I didn’t do anything between deleting 
postgresql83 on Tuesday afternoon and trying to print something on Wednesday 

Anyway, I apologize for the error. As always, I appreciate the help and advice 
I receive here.

Mike Newman
Korat, Thailand

Reply via email to