Have  you tried running

port clean installed

which I would think would eliminate the "do not match those the build was 
started with" errors.

> On Nov 2, 2019, at 02:31, raf <macpo...@raf.org> wrote:
> 
> hi,
> 
> i've recently upgraded a laptop from 10.11 to mojave (10.14) and followed the
> instructions for macports migration and ran into some troubles.
> 
> at first, i changed my macports.conf to put i386 back into the universal_archs
> variable but later found out that xcode (i guess) no longer supports compiling
> for i386 so i changed it back to the default.
> 
> restore_ports.tcl had trouble processing my myports.txt file becaise it
> included some universal ports with i386.
> 
> i thought deleting the i386 from archs='x86_64 i386' in myports.txt would fix
> it but it didn't. now i get errors that say:
> 
>  Error: Requested variants "" do not match those the build was started with: 
> "+universal".
>  Error: Please use the same variants again, or run 'port clean ncurses' first 
> to remove the existing partially completed build.
>  Error: See 
> /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_ncurses/ncurses/main.log
>  for details.
> 
> i then notied that those ports in myports.txt also inluded "+universal"
> so i deleted that. i also deleted the non-active ports.
> 
> i think it still got the same errors as above. so i uninstalled all installed
> ports and then tried to just installed the ports listed in my requested.txt
> file one at a time. i started with MavVim and got this output:
> 
>  $ sudo port install MacVim         
>  --->  Computing dependencies for MacVim
>  The following dependencies will be installed: 
>   gettext
>   libiconv
>   ncurses
>  Continue? [Y/n]: 
>  --->  Fetching archive for libiconv
>  --->  Attempting to fetch libiconv-1.16_0.darwin_18.x86_64.tbz2 from 
> http://nou.nc.packages.macports.org/pub/macports/packages.macports.org/libiconv
>  --->  Attempting to fetch libiconv-1.16_0.darwin_18.x86_64.tbz2.rmd160 from 
> http://nou.nc.packages.macports.org/pub/macports/packages.macports.org/libiconv
>  --->  Installing libiconv @1.16_0
>  --->  Activating libiconv @1.16_0
>  --->  Cleaning libiconv
>  Error: Requested variants "" do not match those the build was started with: 
> "+universal".
>  Error: Please use the same variants again, or run 'port clean ncurses' first 
> to remove the existing partially completed build.
>  Error: See 
> /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_ncurses/ncurses/main.log
>  for details.
>  Error: Follow https://guide.macports.org/#project.tickets to report a bug.
>  Error: Processing of port MacVim failed
> 
> there was a similar error for libiconv at some point.
> 
> any idea what i need to do? as far as i know, i didn't start the build with 
> "+universal"
> as it claims. note that this isn't using myports.txt or requested.txt. i just 
> tried
> to install the MacVim port manually.
> 
> the .../ncurses/main.log file that mentions contains:
> 
>  ...
>  :debug:sysinfo macOS 10.14 (darwin/18.7.0) arch i386
>  :debug:sysinfo MacPorts 2.6.2
>  :debug:sysinfo Xcode 11.1
>  :debug:sysinfo SDK 10.14
>  :debug:sysinfo MACOSX_DEPLOYMENT_TARGET: 10.14
>  :error:clean ncurses cannot be installed for the configured universal_archs 
> 'x86_64 i386' because the arch(s) 'i386' are
>  version:1
>  ...
>  :debug:sysinfo macOS 10.14 (darwin/18.7.0) arch i386
>  :debug:sysinfo MacPorts 2.6.2
>  :debug:sysinfo Xcode 11.1
>  :debug:sysinfo SDK 10.14
>  :debug:sysinfo MACOSX_DEPLOYMENT_TARGET: 10.14
>  :debug:clean dropping privileges: euid changed to 507, egid changed to 504.
>  :error:clean Requested variants "" do not match those the build was started 
> with: "+universal".
>  :error:clean Please use the same variants again, or run 'port clean ncurses' 
> first to remove the existing partially completed build.
>  :error:clean See 
> /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_ncurses/ncurses/main.log
>  for details.
> 
> which i don't understand because i removed i386 from universal_archs.
> my macports.conf is identical to the new default version.
> 
> it's as though the earlier version of my macports.conf is somehow cached
> somewhere and still having an effect.
> 
> cheers,
> raf
> 

Reply via email to