The problem is that if people have installed languages other than
English the browserid directory is not removed from their instance of
mahara when it is upgraded. They are left with an auth/browserid/lang
folder containing the lang file for that plugin, which causes a warning
message that the plugin cannot be installed.

We cannot programmatically remove the folder, but we can update the
warning message to provide better information on the fix, which is to
manually remove the plugin folder.

-- 
You received this bug notification because you are a member of Mahara
Contributors, which is subscribed to Mahara.
Matching subscriptions: Subscription for all Mahara Contributors -- please ask 
on #mahara-dev or mahara.org forum before editing or unsubscribing it!
https://bugs.launchpad.net/bugs/1745886

Title:
  Remove persona plugin: we need to remove lang directories inside
  auth/browserid folder

Status in Mahara:
  Confirmed

Bug description:
  for bug 
  https://bugs.launchpad.net/mahara/+bug/1716811

  we still need to remove extra lang directories inside auth/browserid.

  If the Mahara instance being upgraded to 17.10 has other languages then 
auth/browserid directory will not be removed and we will see error:
  (lib/upgrade.php:167) Plugin auth browserid is not installable: Plugin auth 
browserid is missing version.php

To manage notifications about this bug go to:
https://bugs.launchpad.net/mahara/+bug/1745886/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~mahara-contributors
Post to     : mahara-contributors@lists.launchpad.net
Unsubscribe : https://launchpad.net/~mahara-contributors
More help   : https://help.launchpad.net/ListHelp

Reply via email to