[
https://issues.apache.org/jira/browse/MAHOUT-46?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12779772#action_12779772
]
Sean Owen commented on MAHOUT-46:
---------------------------------
Propose we close this as will not fix, mostly on the grounds it was never done.
There are lots of usages of these as array indexes, which, yes, must now be
followed with ".intValue()" which harms readability a little. This is a small
drag on performance too, in what might be some critical sections.
> Refactor AbstractMatrix.COL and ROW to an enumeration
> -----------------------------------------------------
>
> Key: MAHOUT-46
> URL: https://issues.apache.org/jira/browse/MAHOUT-46
> Project: Mahout
> Issue Type: Improvement
> Reporter: Karl Wettin
> Priority: Trivial
>
> Cosmetic reasons only.
> Allows for importing the enumeration in any class and use ROW.intValue()
> instead of AbstractMatrix.ROW.
> Another argument is that an enumeration could hold further meta data, but I
> don't see any use case.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.