On 21 Sep 2026, at 10:54, Jörg Backschues via mailop wrote:

> Am 21.09.26 um 09:51 schrieb Sebastian Hagedorn via mailop:
>
>> our help desk has notified me that mails from our SIEVE-based vacation 
>> autoresponder aren’t accepted by Microsoft anymore. Microsoft complains 
>> about the From address:
>>
>> "The sender's domain in the 5322.From address doesn't meet the 
>> authentication requirements defined for the sender"
>>
>> I am guessing that refers to the envelope From, which is <> – as it should 
>> be according to RFC 5230. The header From is using our domain, the outgoing 
>> messages are DKIM-signed, and we have a DMARC policy. Regular messages are 
>> accepted by Microsoft, so my best guess is that the empty envelope From is 
>> causing the problem. Is anybody else seeing this? I don’t see how we can do 
>> anything about that on our end.
>
> Your SPF "HELO" identity ist missing
>
> kdig txt mail-out-v1.uni-koeln.de
>
> RFC 7028 Sec. 2.4
> "[RFC5321] allows the reverse-path to be null (see Section 4.5.5 in
> RFC5321]).  In this case, there is no explicit sender mailbox, and
> such a message can be assumed to be a notification message from the
> mail system itself.  When the reverse-path is null, this document
> defines the "MAIL FROM" identity to be the mailbox composed of the
> local-part "postmaster" and the "HELO" identity (which might or might
> not have been checked separately before)."
>
> e.g.
>
> kdig txt mail-out-v1.uni-koeln.de.
>
> mail-out-v1.uni-koeln.de TXT "v=spf1 ip4:134.95.86.58 ip6:2a00:a200:0:13::58 
> -all"


Thanks, I wasn’t aware of that. I have now added the pertinent records. For the 
archive, it’s RFC 7208, not RFC 7028.

Cheers,
Sebastian
-- 
   .:.Sebastian Hagedorn - Weyertal 121 (Gebäude 133), Zimmer 2.13.:.
                .:.IT Center University of Cologne (ITCC).:.
  .:.Universität zu Köln / Cologne University - ✆ +49-221-470-89578.:.
           .:. SIP: [email protected] .:.

Attachment: smime.p7s
Description: S/MIME digital signature

_______________________________________________
mailop mailing list
[email protected]
https://list.mailop.org/listinfo/mailop

Reply via email to