On 03/02/2018 12:34 AM, Anoop C S wrote:
> On Fri, 2018-03-02 at 10:11 +0530, Ravishankar N wrote:
>> + Anoop.
>>
>> It looks like clients on the old (3.12) nodes are not able to talk to 
>> the upgraded (4.0) node. I see messages like these on the old clients:
>>
>>   [2018-03-02 03:49:13.483458] W [MSGID: 114007] 
>> [client-handshake.c:1197:client_setvolume_cbk] 0-testvol-client-2: 
>> failed to find key 'clnt-lk-version' in the options
> Seems like we need to set clnt-lk-version from server side too similar to 
> what we did for client via
> https://review.gluster.org/#/c/19560/. Can you try with the attached patch?
> 

Used the same, and tests on my end pass as well. Backported the same to
4.0 (so that by EOD it is ready for a merge).

Thanks Anoop and Ravi for that quick turnaround, considering 4.0 release
times.

Shyam
_______________________________________________
maintainers mailing list
maintainers@gluster.org
http://lists.gluster.org/mailman/listinfo/maintainers

Reply via email to