Excerpts from Philip Brown's message of Thu Apr 07 14:20:33 -0400 2011: > This is a new naming scheme.
Yes, it's borne out of the ruby dublin discussions. > seems like we should have documentation for, and agreement on, this > new standard, before releasing stuff like that. http://wiki.opencsw.org/ruby-dublin > Or, if you want to just release something without need for discussion, > seems like > ruby18_libxml_ The rb_ standard was good and this is the logical extension of the prefix for a world where a gem will be for 1.8 or 1.9. The new naming scheme also allows for multiple gem versions to live on the system at once (the same capability that gem offers if you install manually). This eases the update burden over time as we don't need to provide a transition path from one set of gems (think rails) to another, where the upstream community has made incompatible changes. It's basically the same idea that drives our library splitting. Discuss. :) Thanks -Ben -- Ben Walton Systems Programmer - CHASS University of Toronto C:416.407.5610 | W:416.978.4302 _______________________________________________ maintainers mailing list [email protected] https://lists.opencsw.org/mailman/listinfo/maintainers .:: This mailing list's archive is public. ::.
