On 28 Mar 2011, at 08:17, Maciej Bliziński wrote: > 2011/3/27 Peter Bonivart <[email protected]>: >> + if [ "$SMF_STATE" = "enabled" ] || [ "$daemon" = "yes" -a >> "$AUTOENABLE" != "no" -a "$AUTOENABLE" != "false" ]; then > > This is a weird syntax, a combination of [ ] and -a. I thought you > could just use -o: > >> + if [ "$SMF_STATE" = "enabled" -o "$daemon" = "yes" -a >> "$AUTOENABLE" != "no" -a "$AUTOENABLE" != "false" ]; then
I would've said -o too - easier to read, if nothing else. _______________________________________________ maintainers mailing list [email protected] https://lists.opencsw.org/mailman/listinfo/maintainers .:: This mailing list's archive is public. ::.
