[ 
https://issues.apache.org/jira/browse/MAPREDUCE-5347?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Pranay Varma resolved MAPREDUCE-5347.
-------------------------------------

    Resolution: Duplicate

duplicate of 5342
                
> getBlacklistedTrackers() should be deprecated and a new method called  
> getNumBlacklistedTrackers should be added. 
> ------------------------------------------------------------------------------------------------------------------
>
>                 Key: MAPREDUCE-5347
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-5347
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>          Components: contrib/streaming, documentation
>    Affects Versions: 2.1.0-beta, 2.0.5-alpha
>            Reporter: Pranay Varma
>
> If the method returns a number, then that is what the method name should 
> reflect. It should be called getNumBlacklistedTrackers(). The method does not 
> return trackers, it returns number of trackers.
> The same applies to the following:
> - getMapTasks, getReduceTasks, getTaskTrackers
> These should be deprecated and a new method should be added: getNumxxx. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to