[
https://issues.apache.org/jira/browse/MAPREDUCE-893?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Vinod K V updated MAPREDUCE-893:
--------------------------------
Attachment: MAPREDUCE-893-20090917.2.txt
Attaching patch that includes the above comments. In particular:
- Documented QueueConfigurationParser's constructor that it also does parsing
itself.
- Renamed scheduler parameter of refreshQueues() to schedulerRefresher.
- Inner class CapacitySchedulerQueueRefresher uses 'initializationPoller'
instance. Left it as is to avoid synthetic constructors.
- getDisplayInfo() is knocked off completely.
TestRefreshOfQueues has minor problems and is being fixed. Everything else can
be reviewed. I'll fix it as the review progresses.
Some questions:
- There is a need for getting a QueueState from a string.
QueueState().valueOf() returns exact name i.e. RUNNING, STOPPED etc, so we
cannot use them directly as display names can be different. Is maintaining the
Queue.QueueState.enumMap bad? What is the standard way of handling this in
enums?
- I left my earlier change which assigns the state UNDEFINED to
Container-Queues. This I did mainly because state doesn't make sense to
Container-Queues - they cannot be stopped, started for e.g. as of now. Is this
not OK?
- Capacity-scheduler.xml still contains the default queue specific properties.
Shouldn't we remove them? If so, where shall the documentation of scheduler
properties be?
- Removed the schedConf instance in scheduler because maintaining it would add
extra effort to keep it consistent during refresh. Is this fine?
- Removed SchedulingDisplayInfo object all together and instead passing
QueueSchedulingContext to the QueueManager directly. Also, the corresponding
queueInfoMap completely. Is this change OK?
- Minor: I am confused about the name TestContainerQueue and what it is
actually testing. Should we rename it to TestHierarchicalQueues or something
like that?
> Provide an ability to refresh queue configuration without restart.
> ------------------------------------------------------------------
>
> Key: MAPREDUCE-893
> URL: https://issues.apache.org/jira/browse/MAPREDUCE-893
> Project: Hadoop Map/Reduce
> Issue Type: Improvement
> Components: jobtracker
> Reporter: Hemanth Yamijala
> Assignee: Vinod K V
> Fix For: 0.21.0
>
> Attachments: MAPREDUCE-893-20090915.1.txt,
> MAPREDUCE-893-20090917.2.txt
>
>
> While administering a cluster using multiple queues, administrators feel a
> need to refresh queue properties on the fly without needing to restart the
> JobTracker. This is partially supported for some properties such as queue
> ACLs (HADOOP-5396) and state (HADOOP-5913). The idea is to extend the
> facility to refresh other queue properties as well, including scheduler
> properties.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.