[
https://issues.apache.org/jira/browse/MAPREDUCE-5227?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Tsuyoshi OZAWA updated MAPREDUCE-5227:
--------------------------------------
Attachment: MAPREDUCE-5227.1.patch
1. Moved prefixed attributes to suffixed atrbiutes.
2. (map|reduce)_blacklisted means blacklisted slots actually, therefore renamed
to map_slots_blacklisted and reduce_slots_blacklisted.
> JobTrackerMetricsSource and QueueMetrics should standardize naming rules
> ------------------------------------------------------------------------
>
> Key: MAPREDUCE-5227
> URL: https://issues.apache.org/jira/browse/MAPREDUCE-5227
> Project: Hadoop Map/Reduce
> Issue Type: Improvement
> Components: mrv1
> Affects Versions: 1.1.2
> Reporter: Tsuyoshi OZAWA
> Assignee: Tsuyoshi OZAWA
> Priority: Minor
> Attachments: MAPREDUCE-5227.1.patch
>
>
> JobTrackerMetricsInst provides users with some metrics, but its naming rules(
> "jobs_running", "running_maps", "running_reduces") sometimes confuses users.
> It should be standardized.
> One concern is backward compatibility, so one idea is to share
> MetricMutableGaugeInt object from old and new property name.
> e.g. to share runningMaps from "running_maps" and "maps_running".
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira