[ 
https://issues.apache.org/jira/browse/MAPREDUCE-5747?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Guilherme updated MAPREDUCE-5747:
---------------------------------
    Attachment: MAPREDUCE-5747-3.patch

I've written a test for the case when type is null, based on the method 
TestBlocks.testHsTasksBlock. It basically sets the type as null and asserts 
that the data must not contain things that are only added when a type is 
available.  I had to move an amount of code to a new method (getAttempts) in 
order to avoid code duplication.

> Potential null pointer deference in HsTasksBlock#render()
> ---------------------------------------------------------
>
>                 Key: MAPREDUCE-5747
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-5747
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>            Reporter: Ted Yu
>            Priority: Minor
>              Labels: BB2015-05-TBR, newbie, patch
>         Attachments: MAPREDUCE-5747-1.patch, MAPREDUCE-5747-2.patch, 
> MAPREDUCE-5747-3.patch
>
>
> At line 140:
> {code}
>         } else {
>           ta = new TaskAttemptInfo(successful, type, false);
> {code}
> There is no check for type against null.
> TaskAttemptInfo ctor deferences type:
> {code}
>   public TaskAttemptInfo(TaskAttempt ta, TaskType type, Boolean isRunning) {
>     final TaskAttemptReport report = ta.getReport();
>     this.type = type.toString();
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to