[
https://issues.apache.org/jira/browse/MAPREDUCE-5044?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Eric Payne updated MAPREDUCE-5044:
----------------------------------
Attachment: MAPREDUCE-5044.010.patch
Thank you very much, [~mingma], for your review and suggestions:
{quote}
- rename {{signalContainer}} to {{signalToContainer}}
{quote}
Done.
{quote}
- {{ContainerManagerImpl}}. It might be cleaner to abstract the common
signal container code to a function used for both {{AM -> NM}} and {{RM -> NM}}
cases.
{quote}
Done.
{quote}
- {{TaskAttemptImpl#PreemptedTransition}}. Given it is called only when the
attempt is preempted, event.getType() == TaskAttemptEventType.TA_TIMED_OUT can
be replaced by false.
{quote}
Very true. Good catch.
{quote}
- It will be useful to add an end-to-end new unit test, which can be found
in Gera's original patch.
{quote}
Done.
{quote}
- Nit: {{ContainerLauncherImpl}}. Return value of
{{getContainerManagementProtocol().signalContainer}} isn't used and can be
removed.
{quote}
Done.
{quote}
- Nit: {{ContainerLauncherEvent}} has indent format issue.
{quote}
Done.
> Have AM trigger jstack on task attempts that timeout before killing them
> ------------------------------------------------------------------------
>
> Key: MAPREDUCE-5044
> URL: https://issues.apache.org/jira/browse/MAPREDUCE-5044
> Project: Hadoop Map/Reduce
> Issue Type: Improvement
> Components: mr-am
> Affects Versions: 2.1.0-beta
> Reporter: Jason Lowe
> Assignee: Gera Shegalov
> Attachments: MAPREDUCE-5044.008.patch, MAPREDUCE-5044.009.patch,
> MAPREDUCE-5044.010.patch, MAPREDUCE-5044.v01.patch, MAPREDUCE-5044.v02.patch,
> MAPREDUCE-5044.v03.patch, MAPREDUCE-5044.v04.patch, MAPREDUCE-5044.v05.patch,
> MAPREDUCE-5044.v06.patch, MAPREDUCE-5044.v07.local.patch, Screen Shot
> 2013-11-12 at 1.05.32 PM.png, Screen Shot 2013-11-12 at 1.06.04 PM.png
>
>
> When an AM expires a task attempt it would be nice if it triggered a jstack
> output via SIGQUIT before killing the task attempt. This would be invaluable
> for helping users debug their hung tasks, especially if they do not have
> shell access to the nodes.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]