[ 
https://issues.apache.org/jira/browse/MAPREDUCE-7032?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16324838#comment-16324838
 ] 

Robert Kanter commented on MAPREDUCE-7032:
------------------------------------------

Some trivial/minor things:
- {{new HashMap<Long, Long>();}} can be just {{new HashMap<>();}}
- The second {{// Start with 0s for each offset}} comment looks like it doesn't 
belong (copy-paste)
-- In fact, we can simplify this loop because the HashMap is already populated. 
 You can use a foreach on an Entry here.
- I think {{blockCount}} can be a {{<Long, Integer>}} map instead of a {{<Long, 
Long>}} map because we're only counting in the value, and it should be less 
than the max replication, which is an integer; then also {{getReplication}} 
should return an {{int}}.
- I think we should rename {{getReplication}} to 
{{getSmallestReplicatedBlockCount}} or something like that

> Add the ability to specify a delayed replication count
> ------------------------------------------------------
>
>                 Key: MAPREDUCE-7032
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-7032
>             Project: Hadoop Map/Reduce
>          Issue Type: Sub-task
>            Reporter: Miklos Szegedi
>            Assignee: Miklos Szegedi
>         Attachments: MAPREDUCE-7032.000.patch, MAPREDUCE-7032.001.patch, 
> MAPREDUCE-7032.002.patch
>
>
> Setting the delayed replication count is more robust



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: mapreduce-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: mapreduce-issues-h...@hadoop.apache.org

Reply via email to