Thanks Steve...
Trying execute a query point like that:
http://localhost/cgi-bin-last/mapserv.exe?map=C:/map.map&mode=query&LAYERS=UF&mapext=-56.798017578125+-14.26017890625+-56.578291015625+-14.04045234375&imgext=-56.798017578125+-14.26017890625+-56.578291015625+-14.04045234375&map_size=1217+680&imgxy=1217+680&img.x=608.5&img.y=340

 generated that error :

msMSSQL2008LayerGetShape(): Query error. Error executing MSSQL2008 SQL
statement: SELECT convert(varchar(max), oid),convert(varchar(max),
codigouf),convert(varchar(max), codigoregiao),convert(varchar(max),
nomeuf),convert(varchar(max),
siglauf),the_geom.STAsBinary(),convert(varchar(20), oid) from viwgeo_uf
WHERE
the_geom.STIntersects(Geometry::STGeomFromText('POLYGON((-56.6879924952826
-14.1504774265924,-56.6879924952826 -14.1504774265924,-56.6879924952826
-14.1504774265924,-56.6879924952826 -14.1504774265924,-56.6879924952826
-14.1504774265924))',0)) = 1

System.FormatException: 24305: The Polygon input is not valid because the
ring does not have enough distinct points. Each ring of a polygon must
contain at least three distinct points. System.FormatException: at
Microsoft.SqlServer.Types.Validator.Execute(Transition transition) at
Microsoft.SqlServer.Types.Validator.EndFigure() at
Microsoft.SqlServer.Types.ForwardingGeoDataSink.EndFigure() at
Microsoft.SqlServer.Types.OpenGisWktReader.ParseLineStringText() at
Microsoft.SqlServer.Types.OpenGisWktReader.ParsePolygonText() at
Microsoft.SqlServer.Types.OpenGisWktReader.ParseTaggedText(OpenGisType type)
at Microsoft.SqlServer.Types.OpenGisWktReader.Read(OpenGisType type, Int32
srid) at Microsoft.SqlServer.Types.SqlGeometry.GeometryFromText(OpenGisType
type, SqlChars text, Int32 srid) at
Microsoft.SqlServer.Types.SqlGeometry.STGeom


Paul


On Fri, Oct 30, 2009 at 2:48 PM, Steve Lime <steve.l...@dnr.state.mn.us>wrote:

> Probably. Does a point query work? I reassigned the ticket to the keeper
> of the SQLServer
> driver in hopes that it gets attention.
>
> Curiously, have you tried 5.6 at all with SQLServer?
>
> Steve
>
> >>> On 10/30/2009 at 12:22 PM, in message
> <33fad6880910301022s40c76f88ha011362964e21...@mail.gmail.com>, Paul
>  james
> <paulj...@gmail.com> wrote:
> > I think so...
> > Is it related with that ticket?
> > http://trac.osgeo.org/mapserver/ticket/3058
> >
> > Paul
> >
> > On Fri, Oct 30, 2009 at 1:53 PM, Steve Lime
> <steve.l...@dnr.state.mn.us>wrote:
> >
> >> Odd. Unfortunately I can't debug anything related to MSSQL2008,
> perhaps
> >> the driver isn't
> >> supporting functions necessary to complete a query?
> >>
> >> Steve
> >>
> >> >>> On 10/30/2009 at 6:33 AM, in message
> >> <33fad6880910300433i342c619am99935a6078966...@mail.gmail.com>, Paul
> >>  james
> >> <paulj...@gmail.com> wrote:
> >> > Hey Steve...
> >> >
> >> > Yes I had...
> >> > QUERYMAP
> >> >  COLOR 255 0 0
> >> >  SIZE -1 -1
> >> >  STATUS ON
> >> >  STYLE hilite
> >> > END
> >> >
> >> > With Status OFF I got that :
> >> > Content-type: text/html
> >> >
> >> > Using MSSQL2008
> >> >
> >> > Paul
> >> >
> >> >
> >> > On Thu, Oct 29, 2009 at 6:13 PM, Steve Lime
> >> <steve.l...@dnr.state.mn.us>wrote:
> >> >
> >> >> Do you have a querymap object configured with status on? I would
> >> guess
> >> >> so in order to see that
> >> >> error. What happens if you set STATUS OFF in the querymap?
> >> >>
> >> >> >>> On 10/29/2009 at 7:57 AM, in message
> >> >> <33fad6880910290557m71ee3fdatd470590e3256f...@mail.gmail.com>,
> Paul
> >> >> james
> >> >> <paulj...@gmail.com> wrote:
> >> >>  > Hello guys...
> >> >> > Ím got this error when trying to execute a Nquery :
> >> >> >
> >> >>
> >> >>
> >> >
> >>
> >>
> >
>
> http://localhost/cgi-bin-54/mapserv.exe?map=Map.map&mode=nquery&LAYERS=TEST&mape
>
> >
> >>
> >> > x
> >> >>
> >> >> >
> >> >>
> >> >>
> >> >
> >>
> >>
> >
>
> t=-58.358076171875+-11.42570625+-57.193525390625+-10.37101875&imgext=-58.35807
> >
> >> > 61718
> >> >> >
> >> >>
> >> >>
> >> >
> >>
> >>
> >
>
> 75+-11.42570625+-57.193525390625+-10.37101875&map_size=1221+762&imgxy=1221+762&i
> >
> >> > mgb
> >> >> > ox=0+0+1221+762
> >> >> >
> >> >> > msDrawMap(): Image handling error. Failed to draw layer named
> >> >> 'TEST'.
> >> >> >
> >> >> > But, If I execute the same url with "mode=map", the image is
> >> >> generated
> >> >> > fine... What this error means?
> >> >> >
> >> >> >
> >> >> > TEST Layer
> >> >> >
> >> >> >  LAYER
> >> >> >   NAME TEST
> >> >> >   GROUP "TE"
> >> >> >   TYPE polygon
> >> >> >   STATUS ON
> >> >> >   CONNECTIONTYPE PLUGIN
> >> >> >   PLUGIN "msplugin_mssql2008.dll"
> >> >> >   CONNECTION "server=X;Integrated
> >> >> Security=false;database=X;uid=X;pwd=X"
> >> >> >   DATA "the_geom from viw USING UNIQUE oid USING SRID=0"
> >> >> >   CLASS
> >> >> >    TEMPLATE "template.html"
> >> >> >    NAME "X"
> >> >> >    STYLE
> >> >> >     OUTLINECOLOR 150 150 150
> >> >> >     WIDTH 1
> >> >> >    END
> >> >> >   END
> >> >> >  END
> >> >> >
> >> >> > Thanks
> >> >> >
> >> >> > Paul
> >> >>
> >>
>
_______________________________________________
mapserver-users mailing list
mapserver-users@lists.osgeo.org
http://lists.osgeo.org/mailman/listinfo/mapserver-users

Reply via email to