Hi Matthew: Looking at the code MapServer 7.0 defaults to 1.3.0 already for 
GetCapabilties requests – you shouldn’t need that line. That said, it should 
work… --Steve

From: mapserver-users [mailto:mapserver-users-boun...@lists.osgeo.org] On 
Behalf Of Cechini, Matthew F. (GSFC-423.0)[Science Systems & Applications, Inc.]
Sent: Wednesday, May 16, 2018 4:22 PM
To: mapserver-users <mapserver-users@lists.osgeo.org>
Subject: [mapserver-users] Default GetCapabilities Version Not Working

All,
   We are running MapServer version 7.0.1 and attempting to use the MAP > WEB > 
METADATA > wms_getcapabilities_version configuration value to support 
GetCapabilities requests that do not supply the VERSION parameter.  
Unfortunately, even if we do add this value to our mapserver configuration 
file, we continue to see the following service exception.  Any suggestions?

msOWSParseVersionString(): OWS error. Invalid version (). Version must be in 
the format 'x.y' or 'x.y.z'

   Here is our METADATA block:


  WEB

    METADATA

      "wms_enable_request"     "GetMap GetCapabilities"

      "wms_title"              "Some Text"

      "wms_abstract"           "Some Text"

      "wms_onlineresource"     "https://our_url?";

      "wms_srs"                "epsg:4326"

      "wms_getcapabilities_version"  "1.3.0"

      "wms_connectiontimeout"  "180"

     END

  END

Thanks,
Matt
.................................................................
Matthew Cechini
Contractor, Science Systems and Applications, Inc.
NASA GIBS Systems/Software Engineer
410.205.6272
_______________________________________________
mapserver-users mailing list
mapserver-users@lists.osgeo.org
https://lists.osgeo.org/mailman/listinfo/mapserver-users
  • ... Cechini, Matthew F. (GSFC-423.0)[Science Systems & Applications, Inc.]
    • ... Lime, Steve D (MNIT)
      • ... Lime, Steve D (MNIT)

Reply via email to