Hi, Sergey! On Apr 13, Sergey Petrunia wrote: > > > > > > Please add a note that this is not the "_rowid" that we support in > > > the parser. > > > > I used the terminology that you introduced, that is > > "keep_current_rowid". > > > > But if you don't mind, I'd rather rename keep_current_rowid (and > > every "rowid" that I introduced) to keep_current_position (because > > it's handler::position()) or keep_current_ref (because it's > > handler::ref and handler::ref_length), whichever is less ambiguous. > > I didn't want to request any renames actually. We use the term "rowid" > in many places in the code. > Until now, there has been no intersection with the SQL-level "_rowid". > Now, with the new Item-derived class I was afraid there would be some > confusion and wanted a comment to prevent it, that's all.
Okay, you didn't want to request it. But would you mind if I introduce a consistent terminology and rename rowid to position where applicable? "ref" is ambiguous, rowid is apparently ambiguous too. position was there forever, since 2000 at least, and it's fairly unambiguous, so I'd rather use it consistently everywhere. Regards, Sergei Chief Architect MariaDB and secur...@mariadb.org _______________________________________________ Mailing list: https://launchpad.net/~maria-developers Post to : email@example.com Unsubscribe : https://launchpad.net/~maria-developers More help : https://help.launchpad.net/ListHelp