Ted Drain wrote:
> John,
> I think keeping the existing API is probably a good idea.  What about 
> something like this:
> 
> - Keep xlim and viewlim as they are.
> 
> - Add xbound() (or maybe a better name) that returns (x1,x2) where x1 < x2.
> 
> - Add set_xbound(x1,x2) that takes x1<x2, checks the inversion flag, and 
> then calls set_xlim() w/ the args in the proper order.

The fundamental object containing the relevant information is the 
Interval instance.  Instead of having a proliferation of flags and 
functions at the python level, I am thinking about adding a few very 
simple methods to the Interval object. Maybe

swap() to reverse the order of the bounds
increasing() to yield True if val2 >= val1

Your xbound and set_xbound functionality could also be done this way, as 
Interval methods.


Mike, how would this fit in with your reworking of transforms?

Eric

> 
> - Change the existing axis code that messes w/ bounds (autoscale, aspect 
> ratio, etc) to use xbound.  These algorithm can then be written so 
> they're independent of the order of x1 and x2 and they won't flip the 
> bounds back if the inversion flag is set.
> 
> Ted

-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >> http://get.splunk.com/
_______________________________________________
Matplotlib-devel mailing list
Matplotlib-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-devel

Reply via email to