John Hunter wrote:
> On Wed, Jun 25, 2008 at 9:23 AM, John Hunter <[EMAIL PROTECTED]> wrote:
>   
>> On Wed, Jun 25, 2008 at 9:09 AM, Michael Droettboom <[EMAIL PROTECTED]> 
>> wrote:
>>     
>>> "rectangle" might be a bad name for "axesPatch" since it can be a circle for
>>> polar plots, and ellipse for geo plots etc.
>>>       
>> Ahh yes, mind still mushy even after a good night's sleep.  "patch" or
>> "background" I feel about the same.  "patch" isn't terribly mnemonic
>> unless you are a matlab user, but at least it points you to the base
>> class and is most consistent with the current name, in which the
>> "figure" part of "figurePatch" is simply redundant.
>>     
>
> I was just confused by the method "get_axes_patch" which looks like an
> accessor method for the axesPatch, but instead is the method that
> generates a new rectangle (or circle or whatever).  To add to the
> confusion, there is the method get_frame, which returns the axesPatch
> even though there is also an axesFrame (which was created by
> get_axes_patch).  Is you head spinning like mine?
>   
Yes, I saw that when I added the transparent kwarg and was also 
confused, but thought best to leave it at the time... ;)
> How about:
>
>    _generate_axes_patch to replace get_axes_patch - internal class use only
>
>    get_frame and get_patch deprecated - just use "patch" and "frame",
> formerly "axesPatch" and "axesFrame".  We'll add a deprecation warning
> to get_frame and keep axesPatch and axesFrame around as aliases.
>
> Michael -- IIRC you added the axesFrame.  Was this to support to
> separate drawing of the edge and face since our patches don't
> (currently) have support for separate alpha channels for edge and
> face.  Or are there additional motivations for the projection
> backends?
It was so that the zorder could be something like:

   axesPatch
   ... data ...
   ... grids ...
   axesFrame

It prevents data from overlapping the axes frame.  This was most crucial 
in the PDF and Cairo backends where the clipping rectangle is 
pixel-aligned but the axes frame and background are not necessarily.  In 
the Agg backend, where we have more fine control, it actually doesn't 
really matter.

Cheers,
Mike

-- 
Michael Droettboom
Science Software Branch
Operations and Engineering Division
Space Telescope Science Institute
Operated by AURA for NASA


-------------------------------------------------------------------------
Check out the new SourceForge.net Marketplace.
It's the best place to buy or sell services for
just about anything Open Source.
http://sourceforge.net/services/buy/index.php
_______________________________________________
Matplotlib-devel mailing list
Matplotlib-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/matplotlib-devel

Reply via email to