Addshore has submitted this change and it was merged.

Change subject: Remove the last manually maintained classmap of doom
......................................................................


Remove the last manually maintained classmap of doom

Change-Id: I35e5a3c68eb298488e86eda8874ed0bca4b256b6
---
M composer.json
M repo/Wikibase.php
2 files changed, 7 insertions(+), 7 deletions(-)

Approvals:
  Addshore: Verified; Looks good to me, approved



diff --git a/composer.json b/composer.json
index 4a613eb..d8c353b 100644
--- a/composer.json
+++ b/composer.json
@@ -48,7 +48,12 @@
 
                        "lib/includes/",
                        "lib/WikibaseLib.hooks.php",
-                       "lib/tests/phpunit/"
+                       "lib/tests/phpunit/",
+
+                       "repo/includes/",
+                       "repo/maintenance/",
+                       "repo/tests/phpunit/",
+                       "repo/Wikibase.hooks.php"
                ]
        }
 }
diff --git a/repo/Wikibase.php b/repo/Wikibase.php
index 383d9d1..4ac1d17 100644
--- a/repo/Wikibase.php
+++ b/repo/Wikibase.php
@@ -30,7 +30,7 @@
 }
 
 call_user_func( function() {
-       global $wgExtensionCredits, $wgAutoloadClasses, $wgGroupPermissions, 
$wgExtensionMessagesFiles;
+       global $wgExtensionCredits, $wgGroupPermissions, 
$wgExtensionMessagesFiles;
        global $wgAPIModules, $wgSpecialPages, $wgSpecialPageGroups, $wgHooks, 
$wgContentHandlers;
        global $wgWBStores, $wgWBRepoSettings, $wgResourceModules;
 
@@ -48,11 +48,6 @@
        // constants
        define( 'CONTENT_MODEL_WIKIBASE_ITEM', "wikibase-item" );
        define( 'CONTENT_MODEL_WIKIBASE_PROPERTY', "wikibase-property" );
-
-       // Autoloading
-       foreach ( include( __DIR__ . '/Wikibase.classes.php' ) as $class => 
$file ) {
-               $wgAutoloadClasses[$class] = __DIR__ . '/' . $file;
-       }
 
        // rights
        // names should be according to other naming scheme

-- 
To view, visit https://gerrit.wikimedia.org/r/108851
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I35e5a3c68eb298488e86eda8874ed0bca4b256b6
Gerrit-PatchSet: 2
Gerrit-Project: mediawiki/extensions/Wikibase
Gerrit-Branch: master
Gerrit-Owner: Jeroen De Dauw <[email protected]>
Gerrit-Reviewer: Addshore <[email protected]>
Gerrit-Reviewer: jenkins-bot <[email protected]>

_______________________________________________
MediaWiki-commits mailing list
[email protected]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits

Reply via email to