Legoktm has uploaded a new change for review.
https://gerrit.wikimedia.org/r/159760
Change subject: HTMLFormFieldCloner: Make sure the delete button has a parent
......................................................................
HTMLFormFieldCloner: Make sure the delete button has a parent
Also fix the type in documentation.
Change-Id: I0fee2dbb9dd1db157acfba2063a2e4e40152cddf
---
M includes/htmlform/HTMLFormFieldCloner.php
1 file changed, 2 insertions(+), 1 deletion(-)
git pull ssh://gerrit.wikimedia.org:29418/mediawiki/core
refs/changes/60/159760/1
diff --git a/includes/htmlform/HTMLFormFieldCloner.php
b/includes/htmlform/HTMLFormFieldCloner.php
index 597a03f..582da7a 100644
--- a/includes/htmlform/HTMLFormFieldCloner.php
+++ b/includes/htmlform/HTMLFormFieldCloner.php
@@ -80,7 +80,7 @@
* specified key.
*
* @param string $key Array key under which these fields should be named
- * @return HTMLFormFields[]
+ * @return HTMLFormField[]
*/
protected function createFieldsForKey( $key ) {
$fields = array();
@@ -303,6 +303,7 @@
'cssclass' =>
'mw-htmlform-cloner-delete-button',
'default' => $this->msg( $label )->text(),
) );
+ $field->mParent = $this->mParent;
$v = $field->getDefault();
if ( $displayFormat === 'table' ) {
--
To view, visit https://gerrit.wikimedia.org/r/159760
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings
Gerrit-MessageType: newchange
Gerrit-Change-Id: I0fee2dbb9dd1db157acfba2063a2e4e40152cddf
Gerrit-PatchSet: 1
Gerrit-Project: mediawiki/core
Gerrit-Branch: master
Gerrit-Owner: Legoktm <[email protected]>
_______________________________________________
MediaWiki-commits mailing list
[email protected]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits