Jeroen De Dauw has submitted this change and it was merged.

Change subject: Remove $parserOptions->setEditSection code in ViewEntityAction
......................................................................


Remove $parserOptions->setEditSection code in ViewEntityAction

This is already done in Article::view (on line 535),
which is called by ViewEntityAction in displayEntityContent
method.

Change-Id: I5d27958ff46ac91f8ccc6f68eb6c9ff68ff24c3e
---
M repo/includes/actions/ViewEntityAction.php
1 file changed, 0 insertions(+), 10 deletions(-)

Approvals:
  Jeroen De Dauw: Looks good to me, approved



diff --git a/repo/includes/actions/ViewEntityAction.php 
b/repo/includes/actions/ViewEntityAction.php
index 5dccc08..a90b437 100644
--- a/repo/includes/actions/ViewEntityAction.php
+++ b/repo/includes/actions/ViewEntityAction.php
@@ -133,17 +133,7 @@
                $outputPage->addJsConfigVars( 'wbIsEditView', $editable );
 
                $user = $this->getContext()->getUser();
-
-               if ( $editable && !$content->isRedirect() ) {
-                       $editable = 
$this->getArticle()->getTitle()->quickUserCan( 'edit', $user );
-               }
-
                $parserOptions = 
$this->getArticle()->getPage()->makeParserOptions( $user );
-
-               if ( !$editable ) {
-                       // disable editing features ("sections" is a misnomer, 
it applies to the wikitext equivalent)
-                       $parserOptions->setEditSection( $editable );
-               }
 
                $this->getArticle()->setParserOptions( $parserOptions );
                $this->getArticle()->view();

-- 
To view, visit https://gerrit.wikimedia.org/r/170695
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I5d27958ff46ac91f8ccc6f68eb6c9ff68ff24c3e
Gerrit-PatchSet: 2
Gerrit-Project: mediawiki/extensions/Wikibase
Gerrit-Branch: master
Gerrit-Owner: Aude <[email protected]>
Gerrit-Reviewer: Aude <[email protected]>
Gerrit-Reviewer: Daniel Kinzler <[email protected]>
Gerrit-Reviewer: Hoo man <[email protected]>
Gerrit-Reviewer: Jeroen De Dauw <[email protected]>
Gerrit-Reviewer: jenkins-bot <>

_______________________________________________
MediaWiki-commits mailing list
[email protected]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits

Reply via email to