Dzahn has submitted this change and it was merged.

Change subject: mediawiki_singlenode: Use require_package instead of package 
latest
......................................................................


mediawiki_singlenode: Use require_package instead of package latest

Bug: T115348
Change-Id: Ia6b14aa2ea4d38e813d1257e455a318ac0859cf3
---
M modules/mediawiki_singlenode/manifests/init.pp
1 file changed, 1 insertion(+), 3 deletions(-)

Approvals:
  jenkins-bot: Verified
  Dzahn: Looks good to me, approved



diff --git a/modules/mediawiki_singlenode/manifests/init.pp 
b/modules/mediawiki_singlenode/manifests/init.pp
index f48f913..565f8ee 100644
--- a/modules/mediawiki_singlenode/manifests/init.pp
+++ b/modules/mediawiki_singlenode/manifests/init.pp
@@ -35,9 +35,7 @@
 
     include ::imagemagick::install
 
-    package { [ 'php-apc', 'php5-cli' ] :
-        ensure => latest,
-    }
+    require_package('php-apc', 'php5-cli')
 
     if !defined(Class['memcached']) {
         class { 'memcached':

-- 
To view, visit https://gerrit.wikimedia.org/r/310703
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: Ia6b14aa2ea4d38e813d1257e455a318ac0859cf3
Gerrit-PatchSet: 4
Gerrit-Project: operations/puppet
Gerrit-Branch: production
Gerrit-Owner: Paladox <thomasmulhall...@yahoo.com>
Gerrit-Reviewer: Alex Monk <a...@wikimedia.org>
Gerrit-Reviewer: Andrew Bogott <abog...@wikimedia.org>
Gerrit-Reviewer: Chasemp <r...@wikimedia.org>
Gerrit-Reviewer: Dzahn <dz...@wikimedia.org>
Gerrit-Reviewer: Paladox <thomasmulhall...@yahoo.com>
Gerrit-Reviewer: Yuvipanda <yuvipa...@wikimedia.org>
Gerrit-Reviewer: jenkins-bot <>

_______________________________________________
MediaWiki-commits mailing list
MediaWiki-commits@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits

Reply via email to