Anomie has uploaded a new change for review.

  https://gerrit.wikimedia.org/r/311798

Change subject: Remove pre-1.25 API compatibility code
......................................................................

Remove pre-1.25 API compatibility code

Since this extension uses extension.json, it already requires 1.25+ so
no need to keep the old code around.

Change-Id: I88622a9a2b5c3a236cc1e2ad2e68b3a61fe678de
---
M includes/ApiQueryAllCampaigns.php
1 file changed, 1 insertion(+), 5 deletions(-)


  git pull ssh://gerrit.wikimedia.org:29418/mediawiki/extensions/UploadWizard 
refs/changes/98/311798/1

diff --git a/includes/ApiQueryAllCampaigns.php 
b/includes/ApiQueryAllCampaigns.php
index ca139f7..bd5b82e 100644
--- a/includes/ApiQueryAllCampaigns.php
+++ b/includes/ApiQueryAllCampaigns.php
@@ -100,11 +100,7 @@
                                );
                        }
                }
-               if ( defined( 'ApiResult::META_CONTENT' ) ) {
-                       $result->addIndexedTagName( [ 'query', 
$this->getModuleName() ], 'campaign' );
-               } else {
-                       $result->setIndexedTagName_internal( [ 'query', 
$this->getModuleName() ], 'campaign' );
-               }
+               $result->addIndexedTagName( [ 'query', $this->getModuleName() 
], 'campaign' );
        }
 
        public function getCacheMode( $params ) {

-- 
To view, visit https://gerrit.wikimedia.org/r/311798
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: I88622a9a2b5c3a236cc1e2ad2e68b3a61fe678de
Gerrit-PatchSet: 1
Gerrit-Project: mediawiki/extensions/UploadWizard
Gerrit-Branch: master
Gerrit-Owner: Anomie <bjor...@wikimedia.org>

_______________________________________________
MediaWiki-commits mailing list
MediaWiki-commits@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits

Reply via email to