jenkins-bot has submitted this change and it was merged.

Change subject: Remove pre-1.25 API compatibility code
......................................................................


Remove pre-1.25 API compatibility code

Since this extension uses extension.json, it already requires 1.25+ so
no need to keep the old code around.

Change-Id: Ia407a3156581f6fcb53041e280e880c9d0daa0cf
---
M SiteMatrixApi.php
1 file changed, 1 insertion(+), 45 deletions(-)

Approvals:
  Jforrester: Looks good to me, approved
  jenkins-bot: Verified



diff --git a/SiteMatrixApi.php b/SiteMatrixApi.php
index d1c5718..7bf0b4a 100644
--- a/SiteMatrixApi.php
+++ b/SiteMatrixApi.php
@@ -224,52 +224,8 @@
                                ApiBase::PARAM_MAX2 => 5000,
                        ),
                        'continue' => array(
-                               /** @todo Once support for MediaWiki < 1.25 is 
dropped, just use ApiBase::PARAM_HELP_MSG directly */
-                               constant( 'ApiBase::PARAM_HELP_MSG' ) ?: '' => 
'api-help-param-continue',
+                               ApiBase::PARAM_HELP_MSG => 
'api-help-param-continue',
                        ),
-               );
-       }
-
-       /**
-        * @deprecated since MediaWiki core 1.25
-        */
-       public function getParamDescription() {
-               return array(
-                       'type' => array(
-                               'Filter the Site Matrix by type',
-                               ' special  - One off, and multilingual 
Wikimedia projects',
-                               ' language - Wikimedia projects under this 
language code',
-                       ),
-                       'state' => array(
-                               'Filter the Site Matrix by wiki state',
-                               ' closed   - No write access, full read access',
-                               ' private  - Read and write restricted',
-                               ' fishbowl - Restricted write access, full read 
access',
-                               ' nonglobal - Public but requires registration',
-                       ),
-                       'langprop' => 'Which information about a language to 
return',
-                       'siteprop' => 'Which information about a site to 
return',
-                       'limit' => 'Maximum number of results',
-                       'continue' => 'When more results are available, use 
this to continue',
-               );
-       }
-
-       /**
-        * @deprecated since MediaWiki core 1.25
-        */
-       public function getDescription() {
-               return array(
-                       'Get Wikimedia sites list',
-                       'The code is either the unique identifier for specials 
else, for languages, the project code',
-               );
-       }
-
-       /**
-        * @deprecated since MediaWiki core 1.25
-        */
-       public function getExamples() {
-               return array(
-                       'api.php?action=sitematrix',
                );
        }
 

-- 
To view, visit https://gerrit.wikimedia.org/r/311792
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: Ia407a3156581f6fcb53041e280e880c9d0daa0cf
Gerrit-PatchSet: 1
Gerrit-Project: mediawiki/extensions/SiteMatrix
Gerrit-Branch: master
Gerrit-Owner: Anomie <bjor...@wikimedia.org>
Gerrit-Reviewer: Jforrester <jforres...@wikimedia.org>
Gerrit-Reviewer: jenkins-bot <>

_______________________________________________
MediaWiki-commits mailing list
MediaWiki-commits@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits

Reply via email to