jenkins-bot has submitted this change and it was merged.

Change subject: Remove pre-1.25 API compatibility code
......................................................................


Remove pre-1.25 API compatibility code

Since this extension uses extension.json, it already requires 1.25+ so
no need to keep the old code around.

Change-Id: I4b78b413c3682eb48b9367fa5e0f56f26806dc30
---
M includes/api/ApiGlobalBlock.php
1 file changed, 0 insertions(+), 4 deletions(-)

Approvals:
  Jforrester: Looks good to me, approved
  jenkins-bot: Verified



diff --git a/includes/api/ApiGlobalBlock.php b/includes/api/ApiGlobalBlock.php
index e169e3c..3ec1f91 100644
--- a/includes/api/ApiGlobalBlock.php
+++ b/includes/api/ApiGlobalBlock.php
@@ -124,8 +124,4 @@
        public function needsToken() {
                return 'csrf';
        }
-
-       public function getTokenSalt() {
-               return '';
-       }
 }

-- 
To view, visit https://gerrit.wikimedia.org/r/311784
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I4b78b413c3682eb48b9367fa5e0f56f26806dc30
Gerrit-PatchSet: 1
Gerrit-Project: mediawiki/extensions/GlobalBlocking
Gerrit-Branch: master
Gerrit-Owner: Anomie <bjor...@wikimedia.org>
Gerrit-Reviewer: Jforrester <jforres...@wikimedia.org>
Gerrit-Reviewer: jenkins-bot <>

_______________________________________________
MediaWiki-commits mailing list
MediaWiki-commits@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits

Reply via email to