Bearloga has uploaded a new change for review.

  https://gerrit.wikimedia.org/r/315885

Change subject: Update R and C++-related stats puppet configs
......................................................................

Update R and C++-related stats puppet configs

- Ensures that g++-4.9 and gfortran-4.9 are both installed on stats machines
  (see http://stackoverflow.com/a/36034866/1091835 for more details)
- Updates documentation in Rakefile, namely adding missing dependencies
  (after I ran into problems getting rake to work correctly)
- Minor formatting changes to some comments
  (to be in line with most comments)
- Ensures GNU Scientific Library is installed on stats machines
  (so that we could install R package 'RcppGSL' later)
- Ensures CRAN recommended packages are installed
  (e.g. Mass, Matrix, boot)
- Ensures that we have r-base-dev, which is used for installing R packages
  that have C++ (& Fortran) code that requires compilation

Bug: T147682
Change-Id: I12227510ed09a8d6be9ef3c2b9b4d2ddf1e9ae08
---
M Rakefile
M modules/statistics/manifests/compute.pp
2 files changed, 24 insertions(+), 13 deletions(-)


  git pull ssh://gerrit.wikimedia.org:29418/operations/puppet 
refs/changes/85/315885/1

diff --git a/Rakefile b/Rakefile
index 79615e6..1b3d884 100644
--- a/Rakefile
+++ b/Rakefile
@@ -1,9 +1,11 @@
 # This rakefile is meant to trigger your local puppet-linter. To take
-# advantage of that powerful linter, you must have the puppet and
-# puppet-lint gems:
+# advantage of that powerful linter, you must have the puppet,
+# puppet-lint, rake (currently 10.4.2), bundler, and rubocop gems:
 #
 #   $ sudo gem install puppet
 #   $ sudo gem install puppet-lint
+#   $ sudo gem install rake -v 10.4.2
+#   $ sudo gem install bundler rubocop
 #
 # Then run the linter using rake (a ruby build helper):
 #
diff --git a/modules/statistics/manifests/compute.pp 
b/modules/statistics/manifests/compute.pp
index 43fdd01..a0460c0 100644
--- a/modules/statistics/manifests/compute.pp
+++ b/modules/statistics/manifests/compute.pp
@@ -25,12 +25,9 @@
         'mercurial',
         'tofrodos',
         'git-review',
-        # halfak wants make to manage dependencies
-        'make',
-        # for checking up on eventlogging
-        'zpubsub',
-        # libwww-perl for wikistats stuff
-        'libwww-perl',
+        'make', # halfak wants make to manage dependencies
+        'zpubsub', # For checking up on eventlogging
+        'libwww-perl', # For wikistats stuff
         'php5-cli',
         'php5-curl',
         'php5-mysql',
@@ -38,7 +35,7 @@
         'libgdal1-dev', # Requested by lzia for rgdal
         'libproj-dev', # Requested by lzia for rgdal
         'libbz2-dev', # for compiling some python libs. T84378
-        'libboost-regex-dev',  # Ironholds wants these
+        'libboost-regex-dev', # Ironholds wants these
         'libboost-system-dev',
         'libyaml-cpp0.3',
         'libyaml-cpp0.3-dev',
@@ -47,7 +44,12 @@
         'libmaxminddb-dev',
         'build-essential', # Requested by halfak to install SciPy
         'nodejs',
-        'openjdk-7-jdk'
+        'openjdk-7-jdk',
+        'g++-4.9',         # Requested by bearloga (Mikhail) to ensure that 
there is a compiler with C++11 support that can compile R package 'Boom'; see 
T147682 and http://stackoverflow.com/a/36034866/1091835 for more info
+        # GNU Scientific Library (GSL) requested by bearloga (Mikhail)
+        'libgsl0ldbl',     # GSL part 1/3
+        'gsl-bin',         # GSL part 2/3
+        'libgsl0-dev'      # GSL part 3/3
     ])
 
     # Python packages
@@ -78,21 +80,28 @@
     # FORTRAN packages (T89414)
     ensure_packages([
         'gfortran',        # GNU Fortran 95 compiler
+        'gfortran-4.9',    # Requested by bearloga (Mikhail); see T147682 and 
http://stackoverflow.com/a/36034866/1091835 for more info
         'liblapack-dev',   # FORTRAN library of linear algebra routines
         'libopenblas-dev', # Optimized BLAS (linear algebra) library
     ])
-
+    
     # Plotting packages
     ensure_packages([
         'ploticus',
         'libploticus0',
-        'r-base',
-        'r-cran-rmysql',
         'libcairo2',
         'libcairo2-dev',
         'libxt-dev'
     ])
 
+    # R packages
+    ensure_packages([
+        'r-base',
+        'r-base-dev',      # Needed for R packages that have to compile C++ 
code; see T147682
+        'r-cran-rmysql',
+        'r-recommended'    # CRAN-recommended packages (e.g. MASS, Matrix, 
boot)
+    ])
+
     # spell checker/dictionary packages for research (halfak)
     # T99030 - for machine learning and natural language processing
     # T121011 - for vandalism detection

-- 
To view, visit https://gerrit.wikimedia.org/r/315885
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: I12227510ed09a8d6be9ef3c2b9b4d2ddf1e9ae08
Gerrit-PatchSet: 1
Gerrit-Project: operations/puppet
Gerrit-Branch: production
Gerrit-Owner: Bearloga <mpo...@wikimedia.org>

_______________________________________________
MediaWiki-commits mailing list
MediaWiki-commits@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits

Reply via email to