jenkins-bot has submitted this change and it was merged.

Change subject: mwscript: allow customizing the PHP version used
......................................................................


mwscript: allow customizing the PHP version used

To allow testing stuff under something other than PHP5,
make the following possible:

PHP=php7.0 mwscript ...

Change-Id: I7ff1ff393fcaaa2ece5d0f266f44497d690cfdd6
---
M puppet/modules/mediawiki/templates/multiwiki/mwscript.erb
1 file changed, 3 insertions(+), 1 deletion(-)

Approvals:
  Yurik: Looks good to me, approved
  jenkins-bot: Verified



diff --git a/puppet/modules/mediawiki/templates/multiwiki/mwscript.erb 
b/puppet/modules/mediawiki/templates/multiwiki/mwscript.erb
index b676180..af5173d 100755
--- a/puppet/modules/mediawiki/templates/multiwiki/mwscript.erb
+++ b/puppet/modules/mediawiki/templates/multiwiki/mwscript.erb
@@ -4,4 +4,6 @@
 # Ensure that the script is run as the www-data user
 [[ $(whoami) = www-data ]] || exec sudo --preserve-env -u www-data -n -- "$0" 
"$@"
 
-exec php5 <%= @script_dir %>/MWScript.php "$@"
+[ "$PHP" = "" ] && PHP=php5
+
+exec $PHP <%= @script_dir %>/MWScript.php "$@"

-- 
To view, visit https://gerrit.wikimedia.org/r/315884
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I7ff1ff393fcaaa2ece5d0f266f44497d690cfdd6
Gerrit-PatchSet: 1
Gerrit-Project: mediawiki/vagrant
Gerrit-Branch: master
Gerrit-Owner: MaxSem <maxsem.w...@gmail.com>
Gerrit-Reviewer: BryanDavis <bda...@wikimedia.org>
Gerrit-Reviewer: Dduvall <dduv...@wikimedia.org>
Gerrit-Reviewer: Yurik <yu...@wikimedia.org>
Gerrit-Reviewer: jenkins-bot <>

_______________________________________________
MediaWiki-commits mailing list
MediaWiki-commits@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits

Reply via email to