Yaron Koren has submitted this change and it was merged.

Change subject: Renamed PFDatePickerInput::textHTML() to genericTextHTML(), for 
clarity
......................................................................


Renamed PFDatePickerInput::textHTML() to genericTextHTML(), for clarity

Change-Id: Ia4c9852bf39becd9a6c6d768b1e87968c1ecc71d
---
M includes/forminputs/PF_DatePickerInput.php
1 file changed, 2 insertions(+), 3 deletions(-)

Approvals:
  Yaron Koren: Looks good to me, approved
  jenkins-bot: Verified



diff --git a/includes/forminputs/PF_DatePickerInput.php 
b/includes/forminputs/PF_DatePickerInput.php
index f95f0ba..3952c1b 100644
--- a/includes/forminputs/PF_DatePickerInput.php
+++ b/includes/forminputs/PF_DatePickerInput.php
@@ -647,7 +647,7 @@
         */
        public function getHtmlText() {
                // Assemble HTML code.
-               $html = self::textHTML( $this->mCurrentValue, 
$this->mInputName, $this->mIsDisabled, $this->mOtherArgs, 'input_' . 
$this->mInputNumber );
+               $html = self::genericTextHTML( $this->mCurrentValue, 
$this->mInputName, $this->mIsDisabled, $this->mOtherArgs, 'input_' . 
$this->mInputNumber );
 
                if ( ! array_key_exists( 'part of dtp', $this->mOtherArgs ) ) {
                        // wrap in span (e.g. used for mandatory inputs)
@@ -684,8 +684,7 @@
         * @param string $class
         * @return string the html text of an input element
         */
-       static function textHTML( $currentValue, $inputName, $isDisabled, 
$otherArgs, $inputId = null, $tabIndex = null, $class = '' ) {
-
+       static function genericTextHTML( $currentValue, $inputName, 
$isDisabled, $otherArgs, $inputId = null, $tabIndex = null, $class = '' ) {
                global $wgPageFormsTabIndex;
 
                // array of attributes to pass to the input field

-- 
To view, visit https://gerrit.wikimedia.org/r/325351
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: Ia4c9852bf39becd9a6c6d768b1e87968c1ecc71d
Gerrit-PatchSet: 2
Gerrit-Project: mediawiki/extensions/PageForms
Gerrit-Branch: master
Gerrit-Owner: Yaron Koren <yaro...@gmail.com>
Gerrit-Reviewer: Yaron Koren <yaro...@gmail.com>
Gerrit-Reviewer: jenkins-bot <>

_______________________________________________
MediaWiki-commits mailing list
MediaWiki-commits@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits

Reply via email to