jenkins-bot has submitted this change and it was merged. ( 
https://gerrit.wikimedia.org/r/371133 )

Change subject: Add hard dependencies on MW version and VE
......................................................................


Add hard dependencies on MW version and VE

* MW 1.30 required for latest OOjs UI (passes with MW master)
* VE required for new editor

Change-Id: I7f835c40ef6814bf0991d06b20d9a3ab46d68c4b
---
M extension.json
1 file changed, 6 insertions(+), 0 deletions(-)

Approvals:
  Catrope: Looks good to me, approved
  jenkins-bot: Verified
  Jforrester: Looks good to me, but someone else must approve



diff --git a/extension.json b/extension.json
index 1976adf..e11087a 100644
--- a/extension.json
+++ b/extension.json
@@ -16,6 +16,12 @@
        "descriptionmsg": "cx-desc",
        "license-name": "GPL-2.0+",
        "type": "specialpage",
+       "requires": {
+               "MediaWiki": ">= 1.30.0",
+               "extensions": {
+                       "VisualEditor": ">= 0.1.0"
+               }
+       },
        "ExtensionMessagesFiles": {
                "ContentTranslationAliases": "ContentTranslation.alias.php"
        },

-- 
To view, visit https://gerrit.wikimedia.org/r/371133
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I7f835c40ef6814bf0991d06b20d9a3ab46d68c4b
Gerrit-PatchSet: 4
Gerrit-Project: mediawiki/extensions/ContentTranslation
Gerrit-Branch: master
Gerrit-Owner: Esanders <esand...@wikimedia.org>
Gerrit-Reviewer: Catrope <r...@wikimedia.org>
Gerrit-Reviewer: Jforrester <jforres...@wikimedia.org>
Gerrit-Reviewer: jenkins-bot <>

_______________________________________________
MediaWiki-commits mailing list
MediaWiki-commits@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits

Reply via email to