jenkins-bot has submitted this change and it was merged.
Change subject: Remove #mw-mf-page-left id
......................................................................
Remove #mw-mf-page-left id
Also, make JS use #mw-mf-page-left instead since that's what contains
the entire left nav now.
Change-Id: Id42763987186b1025ced30c9985cc65b57b12a38
---
M includes/skins/MinervaTemplate.php
M javascripts/common/mf-navigation.js
M javascripts/modules/lazyload.js
3 files changed, 3 insertions(+), 3 deletions(-)
Approvals:
Jdlrobson: Looks good to me, approved
jenkins-bot: Verified
diff --git a/includes/skins/MinervaTemplate.php
b/includes/skins/MinervaTemplate.php
index f05c05d..eea79c5 100644
--- a/includes/skins/MinervaTemplate.php
+++ b/includes/skins/MinervaTemplate.php
@@ -119,7 +119,7 @@
protected function renderMainMenu( $data ) {
?>
- <ul id="mw-mf-menu-main">
+ <ul>
<?php
foreach( $this->getDiscoveryTools() as $key => $val ):
echo $this->makeListItem( $key, $val );
diff --git a/javascripts/common/mf-navigation.js
b/javascripts/common/mf-navigation.js
index 983e0c5..855a5f7 100644
--- a/javascripts/common/mf-navigation.js
+++ b/javascripts/common/mf-navigation.js
@@ -19,7 +19,7 @@
moved = false,
search = document.getElementById( 'searchInput' );
- $( '#mw-mf-menu-main a' ).click( function() {
+ $( '#mw-mf-page-left a' ).click( function() {
toggleNavigation(); // close before following link so
that certain browsers on back don't show menu open
} );
diff --git a/javascripts/modules/lazyload.js b/javascripts/modules/lazyload.js
index 58e7f07..244b634 100644
--- a/javascripts/modules/lazyload.js
+++ b/javascripts/modules/lazyload.js
@@ -15,7 +15,7 @@
// Change UI to reflect new current page - Fix menu
item returnto link
// FIXME: give menu items with returnto=[article]
generic class name
- $( '#mw-mf-menu-main' ).find( '.icon-settings,
.icon-loginout' ).find( 'a' ).each( function() {
+ $( '#mw-mf-page-left' ).find( '.icon-settings,
.icon-loginout' ).find( 'a' ).each( function() {
var href = $( this ).attr( 'href' );
$( this ).attr( 'href',
history.updateQueryStringParameter( href, 'returnto', title ) );
} );
--
To view, visit https://gerrit.wikimedia.org/r/70942
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings
Gerrit-MessageType: merged
Gerrit-Change-Id: Id42763987186b1025ced30c9985cc65b57b12a38
Gerrit-PatchSet: 2
Gerrit-Project: mediawiki/extensions/MobileFrontend
Gerrit-Branch: master
Gerrit-Owner: JGonera <[email protected]>
Gerrit-Reviewer: Jdlrobson <[email protected]>
Gerrit-Reviewer: jenkins-bot
_______________________________________________
MediaWiki-commits mailing list
[email protected]
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits