ATTABOY!

Wilton

----- Original Message ----- From: "Dan Penoff via Mercedes" <mercedes@okiebenz.com>
To: "Okie Benz" <mercedes@okiebenz.com>
Cc: "Dan Penoff" <d...@penoff.com>
Sent: Saturday, September 05, 2015 10:46 AM
Subject: [MBZ] Replacing W140 Motor Mounts


Just finished this job, second time I’ve done it, first time was on the S500 coupe, this time on the 1994 S420.

I bought the special offset wrench for removing the top mount bolt, as it’s buried under the manifolds. Best $15 I ever spent for a special tool for this job. It made it go much faster. I did the passenger (easy) side in about 20 minutes, the driver’s side (difficult) in about 40.

Now I’m heading back out to put the transmission mount in. Pretty easy job on the W140. I’m getting the nasty stuff out of the way early today, then it’s time to spend sorting out the pneumatics. Tomorrow it will be R&R of the right front caliper on the oldest boy’s 98 S420. It’s got a stuck piston. I’ve got a reman caliper waiting in the wings for it.

Dan
_______________________________________
http://www.okiebenz.com

To search list archives http://www.okiebenz.com/archive/

To Unsubscribe or change delivery options go to:
http://mail.okiebenz.com/mailman/listinfo/mercedes_okiebenz.com




_______________________________________
http://www.okiebenz.com

To search list archives http://www.okiebenz.com/archive/

To Unsubscribe or change delivery options go to:
http://mail.okiebenz.com/mailman/listinfo/mercedes_okiebenz.com

Reply via email to