Way to go.

Dwight Giles Jr.
Wickford RI

On Mar 7, 2018 6:20 PM, "Buggered Benzmail via Mercedes" <
mercedes@okiebenz.com> wrote:

> I just put the manifold back on this E300 dizzel and took it out for a
> spin. Wouldn’t get out of first gear no matter what speed/revs.  Engine Ran
> great though. At least I cleaned out the carbon a bit.
>
> Came back home and got out to get the mail and decided to have another go.
> Got out on the road and stomped it, the thing took off like a rocket and
> slammed shifts all the way to 70. Fast. Damn!  Running fine. LOTS of power.
> Steering very tight after replacing those bushings.  I guess the tranny
> just needed to get happy or something.
>
> I cleared the codes and restarted everything. It’s still showing 2 codes
> and the GP light is on so maybe it does have bad plugs. I guess I’ll get a
> set and have at that, but at least it starts ok and runs well now. It was
> idling kinda rough, like missing on a cylinder or two every few seconds.
> But now it is pretty smooth so maybe I just need to run it some and get the
> injectors and such cleaned out. I think I have some techron in the garage,
> guess it wouldn’t hurt to dump that in.
>
> I might keep this car for awhile. It’s half decent. Get the AC sorted out
> for summer, maybe gits summadem cheepcheep New tars fo it. Be stylin.
>
> Man I love it when things work out.
>
> --R
> Sent from iPhone
> _______________________________________
> http://www.okiebenz.com
>
> To search list archives http://www.okiebenz.com/archive/
>
> To Unsubscribe or change delivery options go to:
> http://mail.okiebenz.com/mailman/listinfo/mercedes_okiebenz.com
>
>
_______________________________________
http://www.okiebenz.com

To search list archives http://www.okiebenz.com/archive/

To Unsubscribe or change delivery options go to:
http://mail.okiebenz.com/mailman/listinfo/mercedes_okiebenz.com

Reply via email to