https://bz.mercurial-scm.org/show_bug.cgi?id=5465

            Bug ID: 5465
           Summary: Missing file after reverting directory
           Product: Mercurial
           Version: 4.0.1
          Hardware: PC
                OS: Windows
            Status: UNCONFIRMED
          Severity: bug
          Priority: wish
         Component: Mercurial
          Assignee: bugzi...@mercurial-scm.org
          Reporter: k...@midgie.org
                CC: mercurial-de...@selenic.com

Created attachment 1945
  --> https://bz.mercurial-scm.org/attachment.cgi?id=1945&action=edit
hg verify output

Unfortunately a sporadic issue.

What happens is that after reverting a previously-deleted directory, Mercurial
claims the directory is fully up-to-date but a file is missing in the
directory.

If you create the file, e.g. using hg cat, Mercurial thinks it's a new file.

Has happened on Windows 7 and 10 and with Mercurial 3.7.2. I've double-checked
and there's no issues with file-name case.

The following scenario obviously can't *reliably* reproduce the problem but
would show it when it happens.

% hg init
% mkdir folder
% echo. > folder\a
% echo. > folder\b
% echo. > folder\c

% hg add
% hg commit -m "Test"

% rd /s folder

% hg revert folder
reverting folder\a
reverting folder\b
reverting folder\c

% dir folder

13/01/2017  10:22            3 a
13/01/2017  10:22            3 b

            2 File(s)        6 bytes

% hg stat folder

% hg cat folder\c > folder\c

% hg stat folder
? folder\c

-- 
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
Mercurial-devel mailing list
Mercurial-devel@mercurial-scm.org
https://www.mercurial-scm.org/mailman/listinfo/mercurial-devel

Reply via email to