yuja added inline comments.

INLINE COMMENTS

> indygreg wrote in revset.py:1534
> I'm not sure if the predicate should be prefixed with an underscore to mark 
> it as internal. My reading of the help code is that the lack of a docstring 
> will hide it from the docs.
> 
> I /think/ this is OK. But I wouldn't be surprised if @yuja or someone told me 
> it needs changed. I'll queue this for now. We can always fix it up later if 
> it is a problem.

If it's internal (i.e. shouldn't be accessible by user), `_stack()` is 
preferred.
If it's just experimental, it can be hidden by "(EXPERIMENTAL)"
in docstring.

> revset.py:1541
> +    if x is None:
> +        stacks = stack.getstack(repo, x)
> +    else:

Nit: I prefer `stackmod.` and name the revset function as `stack()`.

REPOSITORY
  rHG Mercurial

REVISION DETAIL
  https://phab.mercurial-scm.org/D2396

To: lothiraldan, #hg-reviewers, indygreg
Cc: martinvonz, yuja, indygreg, mercurial-devel
_______________________________________________
Mercurial-devel mailing list
Mercurial-devel@mercurial-scm.org
https://www.mercurial-scm.org/mailman/listinfo/mercurial-devel

Reply via email to