This revision now requires changes to proceed.
martinvonz added a comment.
martinvonz requested changes to this revision.


  I'm also not sure about the name, but I don't have a better proposal. We can 
revisit that later when it's clearer how it will be used.

INLINE COMMENTS

> utils.rs:154-157
> +        self.iter().fold(vec![], |mut acc, item| {
> +            acc.extend(item.escaped_bytes());
> +            acc
> +        })

i.e. `self.iter().flat_map(|item| item.escaped_bytes()).collect()`?

REPOSITORY
  rHG Mercurial

CHANGES SINCE LAST ACTION
  https://phab.mercurial-scm.org/D7870/new/

REVISION DETAIL
  https://phab.mercurial-scm.org/D7870

To: Alphare, #hg-reviewers, kevincox, martinvonz
Cc: martinvonz, durin42, kevincox, mercurial-devel
_______________________________________________
Mercurial-devel mailing list
Mercurial-devel@mercurial-scm.org
https://www.mercurial-scm.org/mailman/listinfo/mercurial-devel

Reply via email to