Module: Mesa Branch: master Commit: 622858884fc5923c9e7a0c1bb0e80b53f0acb5a7 URL: http://cgit.freedesktop.org/mesa/mesa/commit/?id=622858884fc5923c9e7a0c1bb0e80b53f0acb5a7
Author: Joakim Sindholt <[email protected]> Date: Fri Jun 26 01:08:13 2009 +0200 r300-gallium: organize fragment/vertex shaders Appart from separating r3xx/r5xx fragment shaders, a more consistent naming scheme has been applied. From now on: r300 = all chips r3xx = R300/R400 only r5xx = R500 only This way r300_fragment_shader is the master struct, and the structs r3xx_fragment_shader and r5xx_fragment_shader inherits it. --- src/gallium/drivers/r300/Makefile | 6 +- src/gallium/drivers/r300/SConscript | 6 +- src/gallium/drivers/r300/r300_context.h | 12 +- src/gallium/drivers/r300/r300_debug.c | 54 ++-- src/gallium/drivers/r300/r300_debug.h | 17 +- src/gallium/drivers/r300/r300_emit.c | 8 +- src/gallium/drivers/r300/r300_emit.h | 4 +- src/gallium/drivers/r300/r300_fs.c | 109 ++++++ src/gallium/drivers/r300/r300_fs.h | 36 ++ src/gallium/drivers/r300/r300_fs_inlines.h | 158 +++++++++ src/gallium/drivers/r300/r300_shader_inlines.h | 47 +++ src/gallium/drivers/r300/r300_state.c | 14 +- src/gallium/drivers/r300/r300_state_shader.h | 220 ------------ src/gallium/drivers/r300/r300_surface.c | 16 +- src/gallium/drivers/r300/r300_surface.h | 12 +- .../drivers/r300/{r300_state_tcl.c => r300_vs.c} | 4 +- .../drivers/r300/{r300_state_tcl.h => r300_vs.h} | 17 +- src/gallium/drivers/r300/r3xx_fs.c | 96 ++++++ src/gallium/drivers/r300/r3xx_fs.h | 76 ++++ .../r300/{r300_state_shader.c => r5xx_fs.c} | 361 +++----------------- src/gallium/drivers/r300/r5xx_fs.h | 132 +++++++ 21 files changed, 792 insertions(+), 613 deletions(-) Diff: http://cgit.freedesktop.org/mesa/mesa/diff/?id=622858884fc5923c9e7a0c1bb0e80b53f0acb5a7 _______________________________________________ mesa-commit mailing list [email protected] http://lists.freedesktop.org/mailman/listinfo/mesa-commit
