On 09/07/2016 06:52 PM, Vedran Miletić wrote:
> LLVM and Mesa both define the DEBUG macro in incompatible ways. As a
> general practice, we should avoid using such generic names when it is
> possible to do so.
> This patch renames all occurrences of the DEBUG macro to MESA_DEBUG,
> and removes workarounds previously used to enable building Mesa with
> LLVM (pop_macro() and push_macro() function calls).
> * Rename remaining occurences found by git grep '\<DEBUG\>'
> * Use /* !MESA_DEBUG */ with #else instead of /* MESA_DEBUG */
> Signed-off-by: Vedran Miletić <ved...@miletic.net>
> Acked-by: Christian König <christian.koe...@amd.com>
mesa-dev mailing list