Bug ID: 98263
           Summary: [radv] The Talos Principle fails to launch with "Fatal
                    error: Cannot set display mode."
           Product: Mesa
           Version: git
          Hardware: x86-64 (AMD64)
                OS: Linux (All)
            Status: NEW
          Severity: normal
          Priority: medium
         Component: Drivers/Vulkan/radeon
        QA Contact:
            Blocks: 77449

Created attachment 127305
Error log of "The Talos Principle" when launched with Vulkan

I wanted to test The Talos Principle with my Hawaii GPU (for the full stack see
below). But whenever I launch the game I get the error "Fatal error: Cannot set
display mode." and the attached info is logged to the console.

To launch the game with Vulkan I opted into the Beta (as recommended by
CroTeam) and set »+gfx_strAPI "VLK"« as a command line option (Steam Library →
The Talos Principle → Properties → Set Launch Options → »%command% +gfx_strAPI
"VLK"«), like it was recommended for Linux users by CroTeam in multiple
threads, see eg.
Afterwards I tried to launch the 64-bit version of The Talos Principle.
In case this makes a difference: I've the Road to Gehenna DLC installed.

With OpenGL the game works as expected.

When I run vulkaninfo (from the Debian package vulkan-utils) everything looks
ok/like Vulkan is working.

The stack showing this issue is (Debian testing as a base):
GPU: Hawaii PRO [Radeon R9 290] (ChipID = 0x67b1)
Mesa: Git:master/7dddf0b7ab
libdrm: 2.4.71-1
LLVM: SVN:trunk/r284109 (4.0 devel)
X.Org: 2:1.18.4-2
Linux: 4.8.1
Firmware (firmware-amd-graphics): 20160824-1
libclc: Git:master/520743b0b7
DDX (xserver-xorg-video-amdgpu): 1.1.2-1

Let me know, if you need anything else.

Referenced Bugs:
[Bug 77449] Tracker bug for all bugs related to Steam titles
You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.
mesa-dev mailing list

Reply via email to