Bug ID: 105098
           Summary: [RADV] GPU freeze with simple Vulkan App
           Product: Mesa
           Version: git
          Hardware: x86-64 (AMD64)
                OS: Linux (All)
            Status: NEW
          Severity: normal
          Priority: medium
         Component: Drivers/Vulkan/radeon
        QA Contact:

I tried to start with developing in Vulkan. I finally got something on screen
but after some seconds the system freezes.
I tried also the source from Vulkan Tutorial
( which triggers the
same behaviour.
Some seconds after running an app, which renders fine, the display freezes and
the LEDs on the GPU are full (means 100% GPU load).
It's still possible to ssh but the dmesg shows nothing and hard reset is needed
because shutdown process hangs also. Looks like an infinite loop inside the
On my laptop(AMDGPU OLAND) it runs without freeze(output is a but corrupted but
it's another issue).

Tried with vanilla Kernel 4.15 and drm-next-4.17-wip branch
LLVM 5.0 and 6.0
mesa 18.0.0-RC4 and git
always the same problem and doesn't matter if running under X11/XCB or Wayland.
If I comment out vkQueueSubmit(so it does render nothing), the output is
garbage but it doesn't hang. Maybe a issue with queue handling?

You are receiving this mail because:
You are the assignee for the bug.
You are the QA Contact for the bug.
mesa-dev mailing list

Reply via email to